Bug 856612 - RFE: Allow query filtering by version and/or release
RFE: Allow query filtering by version and/or release
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hawkey (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-12 08:33 EDT by Martin Gracik
Modified: 2014-09-30 19:40 EDT (History)
3 users (show)

See Also:
Fixed In Version: hawkey-0.2.11-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:29:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Gracik 2012-09-12 08:33:26 EDT
The query.filter method allows filtering only by the whole epoch, version, release trio. Sometimes, the epoch can be unknown, so it would be helpful if the query could be filtered by version and/or release only.

Also the package object could have a separate epoch, version and release properties, not just evr.
Comment 1 Ales Kozumplik 2012-09-14 07:56:28 EDT
> Also the package object could have a separate epoch, version and release
> properties, not just evr.

This is working on master now, commit 5aed990.
Comment 2 Ales Kozumplik 2012-09-14 10:03:45 EDT
(In reply to comment #0)
> The query.filter method allows filtering only by the whole epoch, version,
> release trio. Sometimes, the epoch can be unknown, so it would be helpful if
> the query could be filtered by version and/or release only.
> 

Fixed by commit 3adfad5.

Note that epoch filtering is not possible ATM, because there's yet no support in filtering for non-string values (and we want to keep epochs integers).
Comment 3 Fedora Update System 2012-09-21 08:55:47 EDT
hawkey-0.2.11-3.git0245875.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/hawkey-0.2.11-3.git0245875.fc18
Comment 4 Fedora Update System 2012-09-22 02:34:00 EDT
Package hawkey-0.2.11-3.git0245875.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hawkey-0.2.11-3.git0245875.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14575/hawkey-0.2.11-3.git0245875.fc18
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-09-24 03:37:00 EDT
hawkey-0.2.11-4.git687ceab.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/hawkey-0.2.11-4.git687ceab.fc18
Comment 6 Fedora Update System 2012-12-20 10:29:55 EST
hawkey-0.2.11-3.git0245875.fc18 has been pushed to the Fedora 18 obsolete repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.