Bug 856676 - Nautilus refuses to open a Windows share instead of asking for username and password
Nautilus refuses to open a Windows share instead of asking for username and p...
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nautilus (Show other bugs)
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Carlos Soriano
Desktop QE
Depends On:
  Show dependency treegraph
Reported: 2012-09-12 10:50 EDT by Gianni Giardina
Modified: 2017-12-06 05:25 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2017-12-06 05:25:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Anonymous connections to Windows shares with smbclient (1.01 KB, text/plain)
2012-09-12 10:50 EDT, Gianni Giardina
no flags Details

  None (edit)
Description Gianni Giardina 2012-09-12 10:50:39 EDT
Created attachment 612133 [details]
Anonymous connections to Windows shares with smbclient

Description of problem

When you browse to a SMB server (smb://server) and double click the icon of one of the Windows shares other than the system ones (ADMIN$, C$), Nautilus refuses to open the share instead of asking for username/domain/password in order to authenticate you. Nonetheless, Nautilus authenticates you, asking for domain/password, when you directly type in the location bar the share's Url among with you username: smb://user@server/share.

By the way, if you double click one of the Windows system shares, Nautilus asks you for authentication.

Version-Release number of selected component


How reproducible


Steps to Reproduce

1. Share a folder ("share") on your Windows system ("server").
2. Open Nautilus and browse to that system, e.g. by typing "smb://server" in the location bar.
3. Double click the "share" icon. Nautilus fails to open it (see below for the error message).
4. Type the following in the location bar: "smb://user@server/share". Nautilus asks you to provide domain and password and, after successful authentication, opens the shared folder.
Actual results

When you double click the "share" icon, Nautilus opens a pop-up with the following error message:
Unable to mount location

Failed to mount Windows share

Expected results
When you double click the "share" icon, Nautilus should ask you for username/domain/password and, after successful authentication, open the shared folder. This is what it did in RHEL5.

Additional info

I tried with two different Windows XP systems and a Samba server on a Linux machine, always with the same results.

Attached you find what happens when you connect (anonymously) to one of them with smbclient in place of Nautilus.

Finally, I also tried Nautilus on a RHEL 5.8 system and it worked as expected opening the Windows shares of the above systems after successful authentication.
Comment 2 RHEL Product and Program Management 2013-10-13 20:27:37 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 3 Jan Kurik 2017-12-06 05:25:42 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:


This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:


Note You need to log in before you can comment on or make changes to this bug.