Bug 856679 - ipvs: fix oops in ip_vs_dst_event on rmmod
ipvs: fix oops in ip_vs_dst_event on rmmod
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: realtime-kernel (Show other bugs)
2.1
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: John Kacur
David Sommerseth
:
Depends On: 856675
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-12 10:52 EDT by John Kacur
Modified: 2016-05-22 19:35 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 856675
Environment:
Last Closed: 2012-09-18 15:20:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Kacur 2012-09-12 10:52:57 EDT
+++ This bug was initially created as a clone of Bug #856675 +++
(because we need to fix 3.0-rt as well as 3.4-rt)

The following commit is needed

commit 283283c4da91adc44b03519f434ee1e7e91d6fdb
Author: Julian Anastasov <ja@ssi.bg>
Date:   Sat Jul 7 20:30:11 2012 +0300

    ipvs: fix oops in ip_vs_dst_event on rmmod
    
        After commit 39f618b4fd95ae243d940ec64c961009c74e3333 (3.4)
    "ipvs: reset ipvs pointer in netns" we can oops in
    ip_vs_dst_event on rmmod ip_vs because ip_vs_control_cleanup
    is called after the ipvs_core_ops subsys is unregistered and
    net->ipvs is NULL. Fix it by exiting early from ip_vs_dst_event
    if ipvs is NULL. It is safe because all services and dests
    for the net are already freed.

Note You need to log in before you can comment on or make changes to this bug.