Bug 856726 - Cinnamon 1.5.2 applications menu stops working after Windows Applications installation in Crossover
Summary: Cinnamon 1.5.2 applications menu stops working after Windows Applications ins...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cinnamon
Version: 17
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: leigh scott
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-09-12 16:17 UTC by Jack
Modified: 2012-09-19 02:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-09-19 02:57:19 UTC
Type: Bug


Attachments (Terms of Use)

Description Jack 2012-09-12 16:17:03 UTC
Description of problem: After a fresh install of any windows application via Crossover, the primary Cinnamon application menus cease working - none of the application categories will respond to mouse over or mouse click, though the "favorites" on the left side of the Cinnamon menu still work. De-activating the menu item from within Crossover's "Manage Bottles>Control Panel>Edit Menus" tool and then logout/login will restore functionality. 

Note that the installation of Crossover, itself, does not cause this problem. Only the subsequent installation of Windows apps (specifically, the creation of their launcher icons). 

Also of note - Crossover has a "backdoor" method of manually creating a launcher icon within the "Run a Windows Command" tool. Creating launcher icons directly from .exe files using this method does *not* trigger the bug, results in working menu items.

I haven't seen this problem with any other applications using Cinnamon in Fedora, but it's worth noting that this doesn't happen in any other window manager for Crossover users (or earlier versions of Cinnamon).


Version-Release number of selected component (if applicable): Using Crossover 11.0.3+ (most recent version 11.2.1) on Fedora 17, Cinnamon 1.5.2


How reproducible: Every time.


Steps to Reproduce:
1. Install free demo of Crossover - http://www.codeweavers.com/products/#cxlinux
2. Install a free windows app within, such as "e-Sword", "Microsoft Excel Viewer", "Internet Explorer"
3. Upon install completion, try to use the Cinnamon menu.
  
Actual results: Application categories don't respond to mouse over or mouse clicks.


Expected results: Application categories will now feature "windows applications", and working application launchers within.


Additional info: Currently unsure of what additional debug info is needed, but happy to provide any.

Comment 1 leigh scott 2012-09-12 17:53:18 UTC
Sorry I'm not going to test this as I'm not giving my details to codeweavers.
Can you forward this bug to 

https://github.com/linuxmint/Cinnamon/issues

Comment 2 Jack 2012-09-13 16:52:16 UTC
If it makes a difference, you can directly download installers from the links, below (rpm and bin provided), no information necessary:

http://media.codeweavers.com/pub/crossover/cxlinux/demo/crossover-11.2.1-1.i386.rpm

http://media.codeweavers.com/pub/crossover/cxlinux/demo/install-crossover-11.2.1.bin

Or is this issue simply out of the redhat bugzilla's wheelhouse?

Comment 3 leigh scott 2012-09-13 20:49:55 UTC
I can't reproduce the issue here with version 1.5.8, I plan to push it to the repo's within the next week or so.

Comment 4 Fedora Update System 2012-09-18 13:53:08 UTC
cinnamon-1.6.0-1.fc17,muffin-1.1.0-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/cinnamon-1.6.0-1.fc17,muffin-1.1.0-1.fc17

Comment 5 Fedora Update System 2012-09-19 02:57:19 UTC
cinnamon-1.6.0-1.fc17, muffin-1.1.0-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.