Bug 856775 - repo group member add/remove .adds/removes all the repos to/from the group if a filter is not specified.
repo group member add/remove .adds/removes all the repos to/from the group if...
Status: CLOSED DUPLICATE of bug 860408
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
Master
Unspecified Unspecified
unspecified Severity unspecified
: ---
: Sprint 41
Assigned To: Michael Hrivnak
Preethi Thomas
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-12 15:05 EDT by Preethi Thomas
Modified: 2013-09-09 12:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-02 14:04:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2012-09-12 15:05:06 EDT
Description of problem:
repo group member remove .removes all the repos associated with the group if a filter is not specified.

Version-Release number of selected component (if applicable):
[root@preethi-el6-pulp ~]# rpm -q pulp-rpm-server
pulp-rpm-server-2.0.3-1.el6.noarch


How reproducible:


Steps to Reproduce:
1. create a repo group
2. add a couple of the repos to the group
3. run repo group memmber remove on the group without a filter
4. check the repo group
  
Actual results:

root@preethi-el6-pulp ~]# pulp-admin repo group members list --group-id rhel6
+----------------------------------------------------------------------+
                        Repository Group Members
+----------------------------------------------------------------------+

[root@preethi-el6-pulp ~]# pulp-admin repo group members add --group-id rhel6
[root@preethi-el6-pulp ~]# pulp-admin repo group members list --group-id rhel6
+----------------------------------------------------------------------+
                        Repository Group Members
+----------------------------------------------------------------------+

Id:                 zoo
Display Name:       zoo
Description:        None
Content Unit Count: 39
Notes:              

Id:                 test-repo-copy
Display Name:       test-repo-copy
Description:        None
Content Unit Count: 3102
Notes:              

Id:                 rpm
Display Name:       rpm
Description:        None
Content Unit Count: 1
Notes:              

Id:                 rhel6_2
Display Name:       rhel6_2
Description:        None
Content Unit Count: 8541
Notes:              
  Repo: Rhel6

Id:                 preethi
Display Name:       preethi
Description:        None
Content Unit Count: 0
Notes:              

Id:                 old-repo
Display Name:       old-repo
Description:        None
Content Unit Count: 3
Notes:              

Id:                 faux_test_repo
Display Name:       faux_test_repo
Description:        None
Content Unit Count: 3305
Notes:              

Id:                 errata_demo
Display Name:       errata_demo
Description:        None
Content Unit Count: 1
Notes:              

Id:                 bugs
Display Name:       bugs
Description:        None
Content Unit Count: 1
Notes:              


[root@preethi-el6-pulp ~]# pulp-admin repo group members remove --group-id rhel6
[root@preethi-el6-pulp ~]# pulp-admin repo group members list --group-id rhel6+----------------------------------------------------------------------+
                        Repository Group Members
+----------------------------------------------------------------------+

[root@preethi-el6-pulp ~]# 

Expected results:


Additional info:
Comment 1 Michael Hrivnak 2012-10-02 14:04:56 EDT

*** This bug has been marked as a duplicate of bug 860408 ***

Note You need to log in before you can comment on or make changes to this bug.