Bug 856935 - Mongo journal is not preallocated on MongoDB 1.9+
Mongo journal is not preallocated on MongoDB 1.9+
Status: CLOSED UPSTREAM
Product: Katello
Classification: Community
Component: Installer (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lukas Zapletal
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-13 03:42 EDT by Lukas Zapletal
Modified: 2012-09-14 09:11 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-14 09:11:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Zapletal 2012-09-13 03:42:54 EDT
Description of problem:

For MongoDB 1.9+ (Fedora 17+ and Katello/EPEL installations) journal is enabled by default, but installer does not recognize this correctly and does not preallocate journal.

Installation can fail because pulp-migrate does not connect to pulp database.

The fix is to force journal option to true for all supported MongoDB versions and to preallocate it.

This is Katello only bug.
Comment 1 Lukas Zapletal 2012-09-13 10:53:06 EDT
https://github.com/Katello/katello/pull/662

Note You need to log in before you can comment on or make changes to this bug.