Bug 856947 - Hyper-V guest RHEL5.9 remove and then reload the hv_utils module will cause shutdown and heartbeat service not work
Hyper-V guest RHEL5.9 remove and then reload the hv_utils module will cause s...
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.9
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: K. Y. Srinivasan
Virtualization Bugs
:
Depends On:
Blocks: 878362
  Show dependency treegraph
 
Reported: 2012-09-13 04:16 EDT by Bian Jinwei
Modified: 2012-11-20 04:34 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 878362 (view as bug list)
Environment:
Last Closed: 2012-09-16 05:58:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
heartbeat_and_shutdown_status_info (109.23 KB, image/png)
2012-09-13 04:16 EDT, Bian Jinwei
no flags Details

  None (edit)
Description Bian Jinwei 2012-09-13 04:16:27 EDT
Created attachment 612371 [details]
heartbeat_and_shutdown_status_info

Description of problem:
Install a guest rhel5.9 with kernel2.6.18-339.el5 on Hyper-v platform,heartbeat and shutdown service is ok by view the status on Hyper-V manager and click the button"shutdown" on the Hyper-V manager,then on the guest rhel5.9 execute the command "rmmod hv_utils",the heartbeat status on the Hyper-V manger wil become to "lost communication",(hearbeat_and_shutdown.png)click the shutdown button the shutdown button will not work with a pop-up window(hearbeat_and_shutdown.png),then execute the command "modprobe hv_utils""lsmod|grep hv_utils"the modules is loaded for a while,but the status of heartbeat keep "lost communication"and button "shutdown" on Hyper-V manager still keep the window.

Version-Release number of selected component (if applicable):
The Hyper-V:6.1.7600.16385
The Hyper-V guest:rhel5.9 kernel:2.6.18-339.el5(x86_64)

How reproducible:
100%

Steps to Reproduce:
1.Install the Hyper-V guest with kernel2.6.18-339.el5
2.login the guest,execute the command "rmmod hv_utils"
3.on the guest,execute the command "modprobe hv_utils"
4.check the status Heartbeat on Hyper-V manager,and shutdown the guest by click Hyper-V manager "shutdown" button.
  
Actual results:
After step 4,the status for heartbeat is "lost communication",click the Hyper-V manger "shutdown"button cannot shutdown the guest.

Expected results:
when modprobe the hv_utils the status for heartbeat is "ok",click the Hyper-V manger "shutdown"button can shutdown the guest normally.

Additional info:
After reboot the Hyper-V guest,the Heartbeat status on Hyper-V will be ok and shutdown button on Hyper-V function will work.
Comment 1 Shengnan Wang 2012-09-13 05:25:06 EDT
During the test of kvp deamon, if remove the hv_utils driver and load it again in the guest, fail to get the Linux guest information from GuestIntrinsicExchangeItems on host with the guest hypervkvpd service running. Both x86_64 guest and the i386 guest meet this problem.

[root@localhost ~]# rpm -q hypervkvpd
hypervkvpd-0-0.7.el5
[root@localhost ~]# service hypervkvpd status
hv_kvp_daemon (pid 8206) is running...
Comment 2 Bian Jinwei 2012-09-13 05:36:01 EDT
Supplement:
The issue exist on Hyper-V guest rhel5.9 with platform i386,i386PAE,x86_64
Comment 4 Ronen Hod 2012-09-16 05:58:02 EDT
Closing this bug, since it looks like a (Windows) host bug that RH cannot fix.

Note You need to log in before you can comment on or make changes to this bug.