Bug 856958 - problems with custom disk partitioning during the F18 installation (ALPHA/RC3)
problems with custom disk partitioning during the F18 installation (ALPHA/RC3)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-13 04:47 EDT by Joachim Backes
Modified: 2012-09-13 13:19 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-13 11:00:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Backes 2012-09-13 04:47:11 EDT
Description of problem:
I have a box with 2 disks. First, I think, the disk parti
I choose the first disk with review toggle button  for creating a / and a swap partition on that disk. Then I go back, unselect the first and select the second disk (with review toggle too). Then I create additional entries for /tmp and /home with some size, and select "finish partitioning". Then pressing "back" complains about missing bootable root partition which I created in the first step for the first disk. So I fear:it's not possible to create partitions for /tmp and /home on a second disk in that manner.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 David Lehman 2012-09-13 11:00:07 EDT
The set of disks you last selected is the full set of disks visible to the installer. You cannot control which disk a given partition goes on. This might be added later, but no guarantees.
Comment 2 Máirín Duffy 2012-09-13 11:10:25 EDT
Joachim, do you have a specific reason / need to have / and swap on disk 1 and /tmp /home on disk 2?
Comment 3 Joachim Backes 2012-09-13 11:28:42 EDT
1. I have small disks and few memory so I wanted to test if it's possible to put /tmp and the user data into a partition of a separate disk. Only for testing purposes.

2. As a second step (only for testing purposes too) I plan during the anaconda step of installation to move the swap onto the second disk.

I thought that step 1&2 can be done in one anaconda installation step, but it seems that this is not possible for the moment.

But there is one important aspect: Imagine, you have only 1 disk, and on this disk you have important data (in some partition on this disk) which should not be erased, how can you force the installer to leave this partition untouched but using the rest of the disk for installation? I fear that's not possible too!
Comment 4 Máirín Duffy 2012-09-13 11:34:31 EDT
"But there is one important aspect: Imagine, you have only 1 disk, and on this disk you have important data (in some partition on this disk) which should not be erased, how can you force the installer to leave this partition untouched but using the rest of the disk for installation? I fear that's not possible too!"

Joachim, the desired behavior you describe of leaving pre-existing partitions untouched is definitely the default behavior. 

If you have only one disk that has a partition with data on it and click on it, by default, anaconda will only use space on the disk that is not already allocated. If there is not enough space left on the disk, it will ask you what to do:

http://linuxgrrl.com/fedora-ux/Projects/Anaconda/Prototypes/Previews/9-1_install-destination/9-1-6_screen-destination-makespace.png

We offer to:

- Shrink the pre-existing file system if it's a FS type we can shrink;
- Let you modify your software selection so less software gets installed, requiring less space;
- Add more disks if you have more to add.

If you want to simply wipe the disk, you use the custom partitioning checkbox to open the disk up in the custom partition UI and you can delete the partitions if you like.

The new UI is definitely very, very risk averse to removing any data - much more so than previously. 

Does this make more sense now? What do you think?
Comment 5 Joachim Backes 2012-09-13 11:59:19 EDT
(In reply to comment #4)

Hi Máirín Duffy,

> We offer to:
> 
> - Shrink the pre-existing file system if it's a FS type we can shrink;
> - Let you modify your software selection so less software gets installed,
> requiring less space;
> - Add more disks if you have more to add.
> 
> If you want to simply wipe the disk, you use the custom partitioning
> checkbox to open the disk up in the custom partition UI and you can delete
> the partitions if you like.
> 
> The new UI is definitely very, very risk averse to removing any data - much
> more so than previously. 
> 
> Does this make more sense now? What do you think?

Ooops, that's really very helpful, it makes indeed more sense now.

Thank you very much for your hints.

Joachim
Comment 6 Máirín Duffy 2012-09-13 13:00:56 EDT
Joachim, as a caution - the alpha does not currently behave the way I described, and I apologize sincerely. What I described was the intention / design, and is how it will work by the final release. There are some shortcuts in the alpha release that won't be present in the beta. 

Thanks for helping us test alpha, we really appreciate it!
Comment 7 Joachim Backes 2012-09-13 13:12:57 EDT
Hi Máirín Duffy,

I don't know whether this is the right place, but I saw some more issue:

In the meantime I attached a third disk for additional testing. But now, the window for selecting the disk to manage has a scrollbar, and if I select the well known "customize" dialog for installing the system on this third disk, the disk editor is positioned on the left upper side of the anaconda window, and the menu moving/adding partitions is very difficult to operate because this window

1. is very tiny and
2. the usage of the scrollbars makes it very difficult to add/remove/manage partitions. I guess the size of this (sub)windows is about 100x50.

It should be greater. This is a very urgent request!!!

Thanx and kind regards

Joachim
Comment 8 Máirín Duffy 2012-09-13 13:19:47 EDT
Joachim - can you file that as a separate bug and attach a screenshot, if possible? That definitely needs to be looked at - thanks!

Note You need to log in before you can comment on or make changes to this bug.