Bug 856998 - Redundant message displayed on console when clicking menu "Help -> Online Documentation" in subscription-manager-gui in RHEL 5.9 Client/Workstation
Redundant message displayed on console when clicking menu "Help -> Online Doc...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: candlepin-bugs
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-09-13 06:40 EDT by gaoshang
Modified: 2012-09-20 00:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-20 00:32:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gaoshang 2012-09-13 06:40:29 EDT
Description of problem:
Redundant message displayed on console when clicking menu "Help -> Online Documentation" in subscription-manager-gui, it can be reproduced in RHEL 5.9 Client and Workstation, but in RHEL 5.9 Server it never appears.

Version-Release number of selected component (if applicable):
subscription-manager-gui-1.0.17-1.el5
subscription-manager-firstboot-1.0.17-1.el5
subscription-manager-1.0.17-1.el5
python-rhsm-1.0.6-1.el5

How reproducible:
always

Steps to Reproduce:
1.run command subscription-manager-gui
2.click menu "Help -> Online Documentation" in subscription-manager-gui

Actual results:
After step 2, redundant message displayed on console, as follows:

[root@localhost pki]# subscription-manager-gui
** Message: plugin_get_value 1 (1)

** Message: plugin_get_value 2 (2)

** Message: plugin_get_value 1 (1)

** Message: plugin_get_value 2 (2)

** Message: plugin_get_value 1 (1)

** Message: plugin_get_value 2 (2)

** Message: plugin_get_value 1 (1)

** Message: plugin_get_value 2 (2)

** Message: plugin_get_value 1 (1)

** Message: plugin_get_value 2 (2)

Expected results:

No redundant message displays in the console.

Additional info:
Comment 1 RHEL Product and Program Management 2012-09-13 06:58:56 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Bryan Kearney 2012-09-17 15:21:00 EDT
What version of firefox do you have on the machine? I can not reproduce this with firefox-10.0.7-1.el_8 installed
Comment 3 gaoshang 2012-09-18 02:41:08 EDT
(In reply to comment #2)
> What version of firefox do you have on the machine? I can not reproduce this
> with firefox-10.0.7-1.el_8 installed

This bug can just be reproduced in RHEL 5.9 Workstation and RHEL 5.9 Client but not happened to RHEL 5.9 Server, and for my test machine the firefox version is firefox-10.0.7-1.el5_8.
Comment 4 Bryan Kearney 2012-09-18 11:07:44 EDT
I have redhat desktop installed. Is that the same? if so, I can not reproduce it.
Comment 6 Bryan Kearney 2012-09-19 15:34:47 EDT
the issue is with totem-mozplugin. If you remove that file the error goes away. So, I can reproduce this when that package is there.

Given, that I think this is not a susbcription-manager bug. I am moving to ON_QA. If you agree, please close this out.
Comment 7 gaoshang 2012-09-20 00:32:40 EDT
In RHEL workstation 5.9, by removing totem-mozplugin package as below, the error message indeed goes away :
#rpm -e totem-mozplugin

The totem-mozplugin dosen't exist in RHEL 5.9 server but in RHEL 5.9 Client and Workstation, so the issue just happened to Client/Workstation but not to Server.

Since this issue is caused by the plugin 'totem-mozplugin', so I closed this bug as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.