Bug 857016 - Orbit2 causes connection failures on heavily loaded systems
Orbit2 causes connection failures on heavily loaded systems
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ORBit2 (Show other bugs)
6.4
All Linux
high Severity high
: rc
: ---
Assigned To: Dan Winship
Desktop QE
: OtherQA, ZStream
Depends On:
Blocks: 863735 866469
  Show dependency treegraph
 
Reported: 2012-09-13 07:50 EDT by Parthasarathi Susarla
Modified: 2013-11-14 05:38 EST (History)
7 users (show)

See Also:
Fixed In Version: ORBit2-2.14.17-3.2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-14 05:38:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 662623 None None None 2012-09-13 07:50:40 EDT

  None (edit)
Description Parthasarathi Susarla 2012-09-13 07:50:40 EDT
Description of problem:
GConfd-2 clients fail to connect to the gconfd under heavy load. This leads to various error messages on the console.

Version-Release number of selected component (if applicable):


How reproducible:
Recursively spawning gnome-terminals is a sure shot way to reproduce this issue.


Steps to Reproduce:
1.
2.
3.
  
Actual results:

Errors like the one below:

Failed to summon the GConf demon; exiting.  Failed to contact
configuration server; some
possible causes are that you need to enable TCP/IP networking for
ORBit, or you have stale
NFS locks due to a system crash. See http://projects.gnome.org/gconf/
for information.
(Details -  1: Could not send message to GConf daemon: Message did
not receive a reply
(timeout by message bus))

and:


Failed to summon the GConf demon; exiting.  Failed to contact
configuration server; some
possible causes are that you need to enable TCP/IP networking for
ORBit, or you have stale
NFS locks due to a system crash. See http://projects.gnome.org/gconf/
for information.
(Details -  1: Ping to server error
IDL:omg.org/CORBA/COMM_FAILURE:1.0・・




Expected results:
No Error

Additional info:

* There is a gconfd instance listening to incoming connections
* The gnome-terminals keep spawning and talk to gconfd over ORbit2 sockets
* At some point in time, there is a contention from one of the gnome-terminal instance for a socket file, when it tries to make a connection:

 connect(12, {sa_family=AF_FILE, path="/tmp/orbit-partha/linc-146f-0-6730f10292203"}, 46) = -1 EAGAIN (Resource temporarily unavailable)

* gnome-terminal tries to connect once again, and when it fails this time around, it bails out with the error message that you see printed on screen.

This bug has been fixed in el5: https://bugzilla.redhat.com/show_bug.cgi?id=694451 and has been approved upstream (https://bugzilla.gnome.org/show_bug.cgi?id=662623)
Comment 2 Dan Winship 2012-09-13 10:17:23 EDT
we already have a patch for this, on bug 694451 (against RHEL5, but it would apply to RHEL6 too)
Comment 5 Siddharth Sharma 2012-09-25 05:03:54 EDT
As per comment 4 seems from the case that customer wanted z stream but can we get it fixed in rhel-6.4 or make it in Z stream
Comment 7 RHEL Product and Program Management 2012-10-09 07:38:13 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 8 RHEL Product and Program Management 2012-10-12 13:09:44 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.