Bug 857042 - Attempted to update a stale object: Instance displayed while trying stop instance from a disabled pool.
Attempted to update a stale object: Instance displayed while trying stop inst...
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity medium
: beta2
: ---
Assigned To: Tzu-Mainn Chen
Rehana
: Triaged
: 857037 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-13 08:51 EDT by Aziza Karol
Modified: 2012-12-04 10:19 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Attempts to stop an application in a disabled pool resulted in an "Attempted to update a stale object" error. This fix restricts enabled pool validation to run only when creating applications. Users now stop applications in disabled pools without error.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:19:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
stale error (54.76 KB, image/png)
2012-09-13 08:53 EDT, Aziza Karol
no flags Details

  None (edit)
Description Aziza Karol 2012-09-13 08:51:47 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.create a new pool aziza.
2.launched a mock or ec2 deployment.
3.disabled the pool aziza.
4.Navigate to monitor page,click on the deployment name and click on the stop button.
  
Actual results:
The Instance mock-aziza/f15 was not stopped because Attempted to update a stale object: Instance . see attached screenshot

Note:The above message is displayed only for the first attempt,the second time you try to  stop the same instance it displays "stop action was successfully queued"


Expected results:
Proper message should be displayed.

Additional info:
rpm -qa | grep aeolus
rubygem-aeolus-cli-0.7.0-0.20120912180029git8a46b3f.fc16.noarch
aeolus-conductor-daemons-0.13.0-0.20120912220011gite97ce9e.fc16.noarch
aeolus-configure-2.8.0-0.20120912180027git0b3dad6.fc16.noarch
aeolus-conductor-0.13.0-0.20120912220011gite97ce9e.fc16.noarch
aeolus-all-0.13.0-0.20120912220011gite97ce9e.fc16.noarch
rubygem-aeolus-image-0.6.0-0.20120912180033git902c81c.fc16.noarch
aeolus-conductor-doc-0.13.0-0.20120912220011gite97ce9e.fc16.noarch
Comment 1 Aziza Karol 2012-09-13 08:53:05 EDT
Created attachment 612429 [details]
stale error
Comment 3 Mike Orazi 2012-09-13 14:32:03 EDT
Bucketing for beta2
Comment 5 Matt Wagner 2012-09-19 10:04:20 EDT
Pushed:

commit 8d2b3cda7daf25ad1d114e4d01d477f98851bca3
Author: Tzu-Mainn Chen <tzumainn@redhat.com>
Date:   Wed Sep 19 09:23:03 2012 -0400

    BZ857042 only validate pool_must_be_enabled on create
    
    Signed-off-by: Matt Wagner <matt.wagner@redhat.com>
    (cherry picked from commit 2351ad7d8f8d93be04bc9ab57608821b37de28d5)
Comment 7 Scott Seago 2012-09-19 15:01:40 EDT
*** Bug 857037 has been marked as a duplicate of this bug. ***
Comment 8 Aziza Karol 2012-09-25 02:57:03 EDT
stop action was successfully queued is displayed now.
Instance state is  updated for disabled pool.

verified:
rpm -qa | grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.7.2-1.el6cf.noarch
aeolus-conductor-doc-0.13.14-1.el6cf.noarch
aeolus-configure-2.8.7-1.el6cf.noarch
aeolus-all-0.13.14-1.el6cf.noarch
aeolus-conductor-0.13.14-1.el6cf.noarch
aeolus-conductor-daemons-0.13.14-1.el6cf.noarch
Comment 10 errata-xmlrpc 2012-12-04 10:19:02 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.