Bug 857067 - ejabberd fails after erlang R15B update
ejabberd fails after erlang R15B update
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ejabberd (Show other bugs)
16
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-13 09:47 EDT by Ian Donaldson
Modified: 2012-09-25 03:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-25 03:13:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Donaldson 2012-09-13 09:47:06 EDT
Description of problem:

Today's yum update included R15B of erlang, and now I can no longer
use ejabberd.  It doesn't bind to the port in the config file 
and has this trace in /var/log/ejabberd/ejabberd.log


=INFO REPORT==== 2012-09-13 13:06:27 ===
    application: ejabberd
    exited: {bad_return,
                {{ejabberd_app,start,[normal,[]]},
                 {'EXIT',
                     {badarg,
                         [{erlang,port_control,
                              [stringprep_port,2,"localhost"],
                              []},
                          {stringprep,control,2,[]},
                          {jlib,nodeprep,1,[]},
                          {ejabberd_config,normalize_hosts,2,[]},
                          {ejabberd_config,add_hosts_to_option,2,[]},
                          {lists,foldl,3,[{file,"lists.erl"},{line,1197}]},
                          {ejabberd_config,load_file,1,[]},
                          {ejabberd_config,start,0,[]}]}}}}
    type: temporary


Version-Release number of selected component (if applicable):

From yum.log:

ejabberd was updated about a month ago and has been working fine until
today...

Aug 07 00:45:01 Updated: ejabberd-2.1.11-3.fc16.i686

Today's update which broke ejabberd:

Sep 13 03:09:46 Updated: erlang-crypto-R15B-01.4.fc16.i686
Sep 13 03:09:48 Updated: erlang-compiler-R15B-01.4.fc16.i686
Sep 13 03:09:49 Updated: erlang-hipe-R15B-01.4.fc16.i686
Sep 13 03:09:51 Updated: erlang-syntax_tools-R15B-01.4.fc16.i686
Sep 13 03:09:53 Updated: erlang-kernel-R15B-01.4.fc16.i686
Sep 13 03:09:56 Updated: erlang-stdlib-R15B-01.4.fc16.i686
Sep 13 03:09:59 Updated: erlang-erts-R15B-01.4.fc16.i686
Sep 13 03:10:02 Updated: erlang-mnesia-R15B-01.4.fc16.i686
Sep 13 03:10:03 Updated: erlang-gs-R15B-01.4.fc16.i686
Sep 13 03:10:05 Updated: erlang-runtime_tools-R15B-01.4.fc16.i686
Sep 13 03:10:10 Updated: erlang-wx-R15B-01.4.fc16.i686
Sep 13 03:10:17 Updated: erlang-snmp-R15B-01.4.fc16.i686
Sep 13 03:10:18 Updated: erlang-xmerl-R15B-01.4.fc16.i686
Sep 13 03:10:20 Updated: erlang-asn1-R15B-01.4.fc16.i686
Sep 13 03:10:39 Updated: erlang-public_key-R15B-01.4.fc16.i686
Sep 13 03:10:41 Updated: erlang-ssl-R15B-01.4.fc16.i686
Sep 13 03:10:43 Updated: erlang-inets-R15B-01.4.fc16.i686
Sep 13 03:10:45 Updated: erlang-orber-R15B-01.4.fc16.i686
Sep 13 03:10:46 Updated: erlang-cosEvent-R15B-01.4.fc16.i686
Sep 13 03:10:47 Updated: erlang-et-R15B-01.4.fc16.i686
Sep 13 03:10:49 Updated: erlang-debugger-R15B-01.4.fc16.i686
Sep 13 03:10:56 Updated: erlang-cosTime-R15B-01.4.fc16.i686
Sep 13 03:10:59 Updated: erlang-cosNotification-R15B-01.4.fc16.i686
Sep 13 03:11:00 Updated: erlang-cosProperty-R15B-01.4.fc16.i686
Sep 13 03:11:02 Updated: erlang-edoc-R15B-01.4.fc16.i686
Sep 13 03:11:03 Updated: erlang-appmon-R15B-01.4.fc16.i686
Sep 13 03:11:04 Updated: erlang-observer-R15B-01.4.fc16.i686
Sep 13 03:11:05 Updated: erlang-webtool-R15B-01.4.fc16.i686
Sep 13 03:11:07 Updated: erlang-ssh-R15B-01.4.fc16.i686
Sep 13 03:11:08 Updated: erlang-otp_mibs-R15B-01.4.fc16.i686
Sep 13 03:11:09 Updated: erlang-pman-R15B-01.4.fc16.i686
Sep 13 03:11:10 Updated: erlang-tv-R15B-01.4.fc16.i686
Sep 13 03:11:11 Updated: erlang-erl_docgen-R15B-01.4.fc16.i686
Sep 13 03:11:13 Updated: erlang-cosFileTransfer-R15B-01.4.fc16.i686
Sep 13 03:11:14 Updated: erlang-cosEventDomain-R15B-01.4.fc16.i686
Sep 13 03:11:15 Updated: erlang-cosTransactions-R15B-01.4.fc16.i686
Sep 13 03:11:17 Updated: erlang-percept-R15B-01.4.fc16.i686
Sep 13 03:11:19 Updated: erlang-diameter-R15B-01.4.fc16.i686
Sep 13 03:11:19 Installed: erlang-eldap-R15B-01.4.fc16.i686
Sep 13 03:11:21 Updated: erlang-inviso-R15B-01.4.fc16.i686
Sep 13 03:11:22 Updated: erlang-toolbar-R15B-01.4.fc16.i686
Sep 13 03:11:23 Updated: erlang-ic-R15B-01.4.fc16.i686
Sep 13 03:11:24 Updated: erlang-parsetools-R15B-01.4.fc16.i686
Sep 13 03:11:26 Updated: erlang-eunit-R15B-01.4.fc16.i686
Sep 13 03:11:28 Updated: erlang-jinterface-R15B-01.4.fc16.i686
Sep 13 03:11:33 Updated: erlang-tools-R15B-01.4.fc16.i686
Sep 13 03:11:35 Updated: erlang-sasl-R15B-01.4.fc16.i686
Sep 13 03:11:36 Updated: erlang-test_server-R15B-01.4.fc16.i686
Sep 13 03:11:40 Updated: erlang-dialyzer-R15B-01.4.fc16.i686
Sep 13 03:11:42 Updated: erlang-common_test-R15B-01.4.fc16.i686
Sep 13 03:11:43 Updated: erlang-reltool-R15B-01.4.fc16.i686
Sep 13 03:11:44 Updated: erlang-typer-R15B-01.4.fc16.i686
Sep 13 03:11:45 Updated: erlang-os_mon-R15B-01.4.fc16.i686
Sep 13 03:12:09 Updated: erlang-megaco-R15B-01.4.fc16.i686
Sep 13 03:12:11 Updated: erlang-erl_interface-R15B-01.4.fc16.i686
Sep 13 03:12:13 Updated: erlang-odbc-R15B-01.4.fc16.i686
Sep 13 03:12:17 Updated: erlang-examples-R15B-01.4.fc16.i686
Sep 13 03:12:18 Installed: erlang-R15B-01.4.fc16.i686
Sep 13 03:15:16 Erased: erlang-docbuilder-R14B-04.1.fc16.i686
Sep 13 13:03:40 Installed: erlang-erts-R15B-01.4.fc16.i686
Sep 13 13:03:42 Installed: erlang-kernel-R15B-01.4.fc16.i686
Sep 13 13:03:43 Installed: erlang-crypto-R15B-01.4.fc16.i686
Sep 13 13:03:45 Installed: erlang-hipe-R15B-01.4.fc16.i686
Sep 13 13:03:46 Installed: erlang-syntax_tools-R15B-01.4.fc16.i686
Sep 13 13:03:49 Installed: erlang-stdlib-R15B-01.4.fc16.i686
Sep 13 13:03:50 Installed: erlang-compiler-R15B-01.4.fc16.i686
Sep 13 13:03:52 Installed: erlang-gs-R15B-01.4.fc16.i686
Sep 13 13:03:54 Installed: erlang-mnesia-R15B-01.4.fc16.i686
Sep 13 13:03:55 Installed: erlang-xmerl-R15B-01.4.fc16.i686
Sep 13 13:03:56 Installed: erlang-pman-R15B-01.4.fc16.i686
Sep 13 13:03:58 Installed: erlang-tv-R15B-01.4.fc16.i686
Sep 13 13:03:59 Installed: erlang-toolbar-R15B-01.4.fc16.i686
Sep 13 13:04:00 Installed: erlang-eunit-R15B-01.4.fc16.i686
Sep 13 13:04:01 Installed: erlang-ic-R15B-01.4.fc16.i686
Sep 13 13:04:02 Installed: erlang-parsetools-R15B-01.4.fc16.i686
Sep 13 13:04:03 Installed: erlang-jinterface-R15B-01.4.fc16.i686
Sep 13 13:04:04 Installed: erlang-runtime_tools-R15B-01.4.fc16.i686
Sep 13 13:04:09 Installed: erlang-wx-R15B-01.4.fc16.i686
Sep 13 13:04:12 Installed: erlang-snmp-R15B-01.4.fc16.i686
Sep 13 13:04:13 Installed: erlang-asn1-R15B-01.4.fc16.i686
Sep 13 13:04:14 Installed: erlang-public_key-R15B-01.4.fc16.i686
Sep 13 13:04:16 Installed: erlang-ssl-R15B-01.4.fc16.i686
Sep 13 13:04:17 Installed: erlang-inets-R15B-01.4.fc16.i686
Sep 13 13:04:20 Installed: erlang-orber-R15B-01.4.fc16.i686
Sep 13 13:04:21 Installed: erlang-cosEvent-R15B-01.4.fc16.i686
Sep 13 13:04:23 Installed: erlang-et-R15B-01.4.fc16.i686
Sep 13 13:04:24 Installed: erlang-debugger-R15B-01.4.fc16.i686
Sep 13 13:04:25 Installed: erlang-cosTime-R15B-01.4.fc16.i686
Sep 13 13:04:28 Installed: erlang-cosNotification-R15B-01.4.fc16.i686
Sep 13 13:04:29 Installed: erlang-cosProperty-R15B-01.4.fc16.i686
Sep 13 13:04:30 Installed: erlang-edoc-R15B-01.4.fc16.i686
Sep 13 13:04:31 Installed: erlang-appmon-R15B-01.4.fc16.i686
Sep 13 13:04:32 Installed: erlang-webtool-R15B-01.4.fc16.i686
Sep 13 13:04:33 Installed: erlang-observer-R15B-01.4.fc16.i686
Sep 13 13:04:35 Installed: erlang-ssh-R15B-01.4.fc16.i686
Sep 13 13:04:36 Installed: erlang-otp_mibs-R15B-01.4.fc16.i686
Sep 13 13:04:37 Installed: erlang-erl_docgen-R15B-01.4.fc16.i686
Sep 13 13:04:38 Installed: erlang-cosFileTransfer-R15B-01.4.fc16.i686
Sep 13 13:04:39 Installed: erlang-cosEventDomain-R15B-01.4.fc16.i686
Sep 13 13:04:41 Installed: erlang-cosTransactions-R15B-01.4.fc16.i686
Sep 13 13:04:42 Installed: erlang-percept-R15B-01.4.fc16.i686
Sep 13 13:04:43 Installed: erlang-diameter-R15B-01.4.fc16.i686
Sep 13 13:04:44 Installed: erlang-eldap-R15B-01.4.fc16.i686
Sep 13 13:04:45 Installed: erlang-inviso-R15B-01.4.fc16.i686
Sep 13 13:04:47 Installed: erlang-tools-R15B-01.4.fc16.i686
Sep 13 13:04:48 Installed: erlang-sasl-R15B-01.4.fc16.i686
Sep 13 13:04:49 Installed: erlang-test_server-R15B-01.4.fc16.i686
Sep 13 13:04:50 Installed: erlang-dialyzer-R15B-01.4.fc16.i686
Sep 13 13:04:52 Installed: erlang-common_test-R15B-01.4.fc16.i686
Sep 13 13:04:53 Installed: erlang-reltool-R15B-01.4.fc16.i686
Sep 13 13:04:54 Installed: erlang-typer-R15B-01.4.fc16.i686
Sep 13 13:04:55 Installed: erlang-os_mon-R15B-01.4.fc16.i686
Sep 13 13:05:01 Installed: erlang-megaco-R15B-01.4.fc16.i686
Sep 13 13:05:01 Installed: erlang-esasl-0.1-7.fc15.i686
Sep 13 13:05:02 Installed: erlang-odbc-R15B-01.4.fc16.i686
Sep 13 13:05:04 Installed: erlang-erl_interface-R15B-01.4.fc16.i686
Sep 13 13:05:08 Installed: erlang-examples-R15B-01.4.fc16.i686
Sep 13 13:05:09 Installed: erlang-R15B-01.4.fc16.i686


How reproducible:

100%

Steps to Reproduce:
1. systemctl restart ejabberd.service
2.
3.
  
Actual results:

$ ps -ef|grep jab

ejabberd 21035     1  0 13:06 ?        00:00:00 /usr/lib/erlang/erts-5.9.1/bin/epmd -daemon
ejabberd 21037     1  0 13:06 ?        00:00:02 /usr/lib/erlang/erts-5.9.1/bin/beam.smp -K true -P 250000 -- -root /usr/lib/erlang -progname erl -- -home /var/lib/ejabberd/spool -- -sname ejabberd@XXXXXX -noshell -noinput -noshell -noinput -pa /usr/lib/ejabberd/ebin -mnesia dir "/var/lib/ejabberd/spool" -s ejabberd -sasl sasl_error_logger {file,"/var/log/ejabberd/erlang.log"} -smp auto start 

 ... so the daemon is running it seems but it isn't working

$ telnet thishost xmpp-port       (details obscured)
  - connection refused

and Pidgin can't connect to it

Expected results:

working.

Additional info:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=657759

seems to be a close match to my problem, but they say ejabber 2.1.10-2 has a fix;
but the FC16 version is later than that (2.1.11-3)
Comment 1 Ian Donaldson 2012-09-13 09:48:42 EDT
BTW I rpm -e'd ejabberd, erlang stuff and reinstalled both using yum
but nothing improved.
Comment 2 Ian Donaldson 2012-09-13 09:53:02 EDT
yum.log shows this to be the previous version of erlang installed.  R14B.

Mar 20 23:33:19 Updated: erlang-syntax_tools-R14B-04.1.fc16.i686
Mar 20 23:33:23 Updated: erlang-erts-R14B-04.1.fc16.i686
Mar 20 23:33:25 Updated: erlang-kernel-R14B-04.1.fc16.i686
Mar 20 23:33:28 Updated: erlang-stdlib-R14B-04.1.fc16.i686
Mar 20 23:33:29 Updated: erlang-crypto-R14B-04.1.fc16.i686
Mar 20 23:33:31 Updated: erlang-hipe-R14B-04.1.fc16.i686
Mar 20 23:33:33 Updated: erlang-compiler-R14B-04.1.fc16.i686
Mar 20 23:33:35 Updated: erlang-runtime_tools-R14B-04.1.fc16.i686
Mar 20 23:33:36 Updated: erlang-mnesia-R14B-04.1.fc16.i686
Mar 20 23:33:54 Updated: erlang-snmp-R14B-04.1.fc16.i686
Mar 20 23:33:56 Updated: erlang-xmerl-R14B-04.1.fc16.i686
Mar 20 23:34:03 Updated: erlang-public_key-R14B-04.1.fc16.i686
Mar 20 23:34:33 Updated: erlang-ssl-R14B-04.1.fc16.i686
Mar 20 23:34:35 Updated: erlang-inets-R14B-04.1.fc16.i686
Mar 20 23:34:38 Updated: erlang-orber-R14B-04.1.fc16.i686
Mar 20 23:34:39 Updated: erlang-cosEvent-R14B-04.1.fc16.i686
Mar 20 23:34:43 Updated: erlang-cosTime-R14B-04.1.fc16.i686
Mar 20 23:34:46 Updated: erlang-cosNotification-R14B-04.1.fc16.i686
Mar 20 23:34:48 Updated: erlang-cosProperty-R14B-04.1.fc16.i686
Mar 20 23:34:49 Updated: erlang-edoc-R14B-04.1.fc16.i686
Mar 20 23:34:51 Updated: erlang-ssh-R14B-04.1.fc16.i686
Mar 20 23:34:52 Updated: erlang-otp_mibs-R14B-04.1.fc16.i686
Mar 20 23:34:53 Updated: erlang-docbuilder-R14B-04.1.fc16.i686
Mar 20 23:34:55 Updated: erlang-cosFileTransfer-R14B-04.1.fc16.i686
Mar 20 23:34:56 Updated: erlang-cosEventDomain-R14B-04.1.fc16.i686
Mar 20 23:34:58 Updated: erlang-cosTransactions-R14B-04.1.fc16.i686
Mar 20 23:34:59 Updated: erlang-percept-R14B-04.1.fc16.i686
Mar 20 23:35:05 Updated: erlang-inviso-R14B-04.1.fc16.i686
Mar 20 23:35:08 Updated: erlang-diameter-R14B-04.1.fc16.i686
Mar 20 23:35:09 Updated: erlang-eunit-R14B-04.1.fc16.i686
Mar 20 23:35:12 Updated: erlang-ic-R14B-04.1.fc16.i686
Mar 20 23:35:14 Updated: erlang-parsetools-R14B-04.1.fc16.i686
Mar 20 23:35:15 Updated: erlang-jinterface-R14B-04.1.fc16.i686
Mar 20 23:35:17 Updated: erlang-erl_docgen-R14B-04.1.fc16.i686
Mar 20 23:35:43 Updated: erlang-asn1-R14B-04.1.fc16.i686
Mar 20 23:36:12 Updated: erlang-odbc-R14B-04.1.fc16.i686
Mar 20 23:36:15 Updated: erlang-erl_interface-R14B-04.1.fc16.i686
Mar 20 23:41:21 Updated: erlang-gs-R14B-04.1.fc16.i686
Mar 20 23:41:22 Updated: erlang-pman-R14B-04.1.fc16.i686
Mar 20 23:41:24 Updated: erlang-tv-R14B-04.1.fc16.i686
Mar 20 23:41:26 Updated: erlang-appmon-R14B-04.1.fc16.i686
Mar 20 23:41:28 Updated: erlang-toolbar-R14B-04.1.fc16.i686
Mar 20 23:45:53 Updated: erlang-wx-R14B-04.1.fc16.i686
Mar 20 23:45:55 Updated: erlang-et-R14B-04.1.fc16.i686
Mar 20 23:45:56 Updated: erlang-webtool-R14B-04.1.fc16.i686
Mar 20 23:45:58 Updated: erlang-observer-R14B-04.1.fc16.i686
Mar 20 23:45:59 Updated: erlang-debugger-R14B-04.1.fc16.i686
Mar 20 23:46:01 Updated: erlang-tools-R14B-04.1.fc16.i686
Mar 20 23:46:03 Updated: erlang-sasl-R14B-04.1.fc16.i686
Mar 20 23:46:04 Updated: erlang-test_server-R14B-04.1.fc16.i686
Mar 20 23:46:06 Updated: erlang-dialyzer-R14B-04.1.fc16.i686
Mar 20 23:46:08 Updated: erlang-common_test-R14B-04.1.fc16.i686
Mar 20 23:46:09 Updated: erlang-reltool-R14B-04.1.fc16.i686
Mar 20 23:46:10 Updated: erlang-typer-R14B-04.1.fc16.i686
Mar 20 23:46:12 Updated: erlang-os_mon-R14B-04.1.fc16.i686
Mar 20 23:46:19 Updated: erlang-megaco-R14B-04.1.fc16.i686
Mar 20 23:46:23 Updated: erlang-examples-R14B-04.1.fc16.i686
Mar 20 23:46:25 Updated: erlang-R14B-04.1.fc16.i686
Aug 07 00:34:24 Updated: erlang-rpm-macros-0.1.3-1.fc16.noarch

Is all that is required that ejabberd be rebuilt against R15B maybe?
Comment 3 Peter Lemenkov 2012-09-13 09:56:37 EDT
Hello Ian and sorry for that - I forgot to rebuild ejabberd after Erlang upgrade (it's required for port interface to run). I've got a fixed ejabberd version in updates-testing repository - upgrade with this command:

$ sudo yum upgrade ejabberd --enablerepo updates-testing

Restart after upgrade.
Comment 4 Ian Donaldson 2012-09-13 10:01:55 EDT
Magic.  Worked instantly!

Many thanks for the fast (3 minute!) response.
Comment 5 Ian Donaldson 2012-09-13 10:06:05 EDT
ejabberd-2.1.11-5.fc16.i686

is what I'm running now, BTW
Comment 6 Peter Lemenkov 2012-09-25 03:13:08 EDT
Ok, since ejabberd with fix is available in F-16, I'm closing this.

Note You need to log in before you can comment on or make changes to this bug.