Bug 85714 - fdisk corrupts the file system
fdisk corrupts the file system
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
7.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Elliot Lee
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-06 08:09 EST by Norbert Schulz
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-28 16:51:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Norbert Schulz 2003-03-06 08:09:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020913

Description of problem:
fdisk change the file system during the following procedure: call `fdisk' then
press `p' to see the partition table and after that press `q' to quit fdisk
without saving anything. Then make an fsck over all partitions on the device
from which you had a look at the partition table. In an not so heavy matter fsck
can repair the file systems without any lost of your data. In an very heavy case
the superblock might be corrupted. fsck can repair your file system, but as in
my case the following system directories were moved to lost+found and got
numbers instead of file names: /bin, /etc, /lib, /root, /usr and all
subdirectories of these.
I observed these behavior of fdisk on different computers every time when I do
the above described procedure.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. command `fdisk'
2. then press `p' to see the partition table
3. press `q' to quit without saving
4. run `fsck'
    

Actual Results:  fsck finds different file system errors until corrupted
superblock informations

Expected Results:  no change for the file system

Additional info:
Comment 1 Elliot Lee 2003-04-11 13:16:58 EDT
My guess is that you are doing an fsck on mounted filesystems and that the fdisk
has nothing to do with it. Am I right?
Comment 2 Norbert Schulz 2003-04-11 13:41:09 EDT
No, the fsck is only to see that fdisk with the above steps to reproduce has
made changes to the file system. If you perform `fdisk' with  the 3 steps
everthing seems to be okay. But after fdisk you run fsck on that disk to see
that there was something wrong.

Norbert Schulz
Comment 3 Elliot Lee 2003-04-11 13:48:38 EDT
What happens if you run the fsck's without doing the fdisk?
Comment 4 Norbert Schulz 2003-04-14 05:49:59 EDT
Fdisk is the problem. To get the error do the following:
1. run `fdisk'
2. while you are in fdisk press `p' to see the partition table
3. press `q' to quit fdisk
4. reboot your system

Be carefull to see what happens during the boot of your system. You should be
enforced to check the filesystem.

Norbert Schulz
Comment 5 Elliot Lee 2004-07-28 16:51:42 EDT
This bug is kind of old (for which I apologize, since it's my fault)
and I don't have any good ideas on fixing it since I can't reproduce
it. It's also against RHL 7.2, suggesting that there's a good chance
it has since been fixed. If you can reproduce with FC2 or RHEL3,
please re-open the bug by all means.

Note You need to log in before you can comment on or make changes to this bug.