Bug 857143 - JBoss hot_deploy fails for https://github.com/bdecoste/JUDCon2012
JBoss hot_deploy fails for https://github.com/bdecoste/JUDCon2012
Status: CLOSED WONTFIX
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Bill DeCoste
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-13 12:32 EDT by Bill DeCoste
Modified: 2015-05-14 19:16 EDT (History)
4 users (show)

See Also:
Fixed In Version: devenv_2222
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-22 15:20:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill DeCoste 2012-09-13 12:32:16 EDT
Description of problem:
Components from https://github.com/bdecoste/JUDCon2012 do not redeploy properly when using hot_deploy



Version-Release number of selected component (if applicable):


How reproducible:
100%


Steps to Reproduce:
1. Follow steps from https://github.com/bdecoste/JUDCon2012
2. Add hot_deploy and push
3.
  
Actual results:
Should redeploy properly


Expected results:
Fails


Additional info:
Comment 1 Xiaoli Tian 2012-09-25 01:31:04 EDT
Move it to ON_QA since this pull request is merged to devenv_2222. https://github.com/openshift/crankcase/pull/528
Comment 2 Chandrika Gole 2012-09-26 20:04:36 EDT
Bill will be adding a document to elaborate on the steps to deploy this app
Comment 3 Bill DeCoste 2012-10-08 21:11:17 EDT
Follow directions in updated README.md and test hot_deploy. All artifacts should deploy without error
Comment 4 Wei Sun 2012-10-25 06:12:01 EDT
Test this on devenv_2377,follow steps from:https://github.com/bdecoste/JUDCon2012
but when I run step 4:mvn clean install -Dmaven.test.skip=true,have some error

Steps:
1.rhc app create -a as1 -t jbossas-7 -d
2.Download this git repo
  cd as1/
  git remote add upstream -m master git://github.com/bdecoste/JUDCon2012
  git pull -s recursive -X theirs upstream master
 git push
3.Replace every occurence of 127.*.*.* with the value of OPENSHIFT_INTERNAL_IP
grep -r 127.*.*.* | sed -e 's/127.*.*.*/127.0.252.1/g'
4.mvn clean install -Dmaven.test.skip=true

Result:
/usr/lib/jvm/java
[INFO] Scanning for projects...
[INFO]                                                                         
[INFO] ------------------------------------------------------------------------
[INFO] Building jboss2 1.0
[INFO] ------------------------------------------------------------------------
[WARNING] The POM for org.judcon:caching:jar:1.0 is missing, no dependency information available
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 0.950s
[INFO] Finished at: Thu Oct 25 18:11:21 CST 2012
[INFO] Final Memory: 6M/92M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal on project jboss1: Could not resolve dependencies for project jboss1:jboss1:war:1.0: Failure to find org.judcon:caching:jar:1.0 in https://repository.jboss.org/nexus/content/groups/public-jboss/ was cached in the local repository, resolution will not be reattempted until the update interval of jboss-public-repository-group has elapsed or updates are forced -> [Help 1]
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/DependencyResolutionException
Comment 5 Bill DeCoste 2012-10-25 08:36:52 EDT
Looks like the pre_build action hooks did not execute properly. Can you confirm that caching-1.0.jar is in the root directory of your local git repo and .openshift/action_hooks/pre_build contains these lines?

mvn install:install-file -Dfile=../../app-root/repo/caching-1.0.jar -DgroupId=org.judcon -DartifactId=caching -Dversion=1.0 -Dpackaging=jar

mvn install:install-file -Dfile=../../app-root/repo/deployments/OrderService.jar -DgroupId=org.switchyard.quickstarts.demos -DartifactId=switchyard-quickstart-demo-multi-artifacts -Dversion=0.4.0.Final -Dpackaging=jar
Comment 6 Chandrika Gole 2012-10-25 19:11:39 EDT
On dev2383, I can't get past git push in Step 2. I keep getting this error - 

[root@ip-10-98-87-6 as1]# git push
The authenticity of host 'as1-cgolecad.dev.rhcloud.com (10.98.87.6)' can't be established.
RSA key fingerprint is 26:95:f3:14:79:08:14:61:13:15:34:13:5b:d4:97:a0.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added 'as1-cgolecad.dev.rhcloud.com,10.98.87.6' (RSA) to the list of known hosts.
Counting objects: 2032, done.
Compressing objects: 100% (1052/1052), done.
Writing objects: 100% (2029/2029), 161.59 MiB | 1.88 MiB/s, done.
Total 2029 (delta 470), reused 2025 (delta 468)
error: index-pack died of signal 9
error: unpack failed: index-pack abnormal exit
To ssh://22f1202cdc5646d28d0e03218e5ce130@as1-cgolecad.dev.rhcloud.com/~/git/as1.git/
 ! [remote rejected] master -> master (n/a (unpacker error))
error: failed to push some refs to 'ssh://22f1202cdc5646d28d0e03218e5ce130@as1-cgolecad.dev.rhcloud.com/~/git/as1.git/'
Comment 7 Chandrika Gole 2012-10-25 19:14:54 EDT
Response for Comment 5 - 
caching-1.0.jar is not in the root dir

[root@ip-10-98-87-6 as1]# ls
a1  artifacts  bpm-service  caching  deployments  jboss  order-consumer  order-service  pom.xml  README  README.md  README.md~  restful-order  rules-camel-cbr  src  test.sh  web



.openshift/action_hooks/pre_build doesn't have those lines

Contents of .openshift/action_hooks/pre_build ===


#!/bin/bash
# This is a simple script and will be executed on your CI system if
# available.  Otherwise it will execute while your application is stopped
# before the build step.  This script gets executed directly, so it
# could be python, php, ruby, etc.
Comment 8 Bill DeCoste 2012-10-25 19:25:06 EDT
I've updated the readme to be more clear.
Comment 9 Chandrika Gole 2012-10-25 19:57:33 EDT
Tried it with the new README.. The maven install fails with a slightly different error now - 

[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 11.824s
[INFO] Finished at: Thu Oct 25 19:50:30 EDT 2012
[INFO] Final Memory: 5M/15M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal on project jboss1: Could not resolve dependencies for project jboss1:jboss1:war:1.0: The following artifacts could not be resolved: org.switchyard.quickstarts.demos:switchyard-quickstart-demo-multi-artifacts:jar:0.4.0.Final, org.judcon:caching:jar:1.0: Could not find artifact org.switchyard.quickstarts.demos:switchyard-quickstart-demo-multi-artifacts:jar:0.4.0.Final in central (http://repo1.maven.org/maven2) -> [Help 1]
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/DependencyResolutionException

Note You need to log in before you can comment on or make changes to this bug.