Bug 857157 - Make working directory if needed
Make working directory if needed
Status: CLOSED NOTABUG
Product: Fedora EPEL
Classification: Fedora
Component: rpmrebuild (Show other bugs)
el6
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Anderson Silva
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-13 13:06 EDT by Orion Poplawski
Modified: 2013-02-13 09:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-13 09:50:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2012-09-13 13:06:29 EDT
Description of problem:

$ rpmrebuild --edit-provides -p hdf5189-intel-openmpi-1.8.9-2.el6.x86_64.rpm
Do you want to continue ? (y/N) y
/tmp/rpm/rpm-tmp.KR7tjx: line 26: cd: /scratch/orion/redhat/hdf5189-intel-openmpi-1.8.9: No such file or directory
error: Bad exit status from /tmp/rpm/rpm-tmp.KR7tjx (%clean)
    Bad exit status from /tmp/rpm/rpm-tmp.KR7tjx (%clean)
/usr/lib/rpmrebuild/rpmrebuild.sh: ERROR: package 'hdf5189-intel-openmpi-1.8.9-2.el6.x86_64.rpm' build failed

Looks like it may need to create the working directory.  I have:

%_topdir                /scratch/orion/redhat
%_rpmtopdir             %{_topdir}/%{name}-%{version}

In my ~/.rpmmacros.

Version-Release number of selected component (if applicable):
rpmrebuild-2.8-1.el6.noarch
Comment 1 Anderson Silva 2013-02-13 09:50:39 EST
Hi, sorry for the late reply. This is not a rpmrebuild issue, but a rpmbuild configuration. rpmrebuild depends on rpmbuild, and it is part of the configuration of rpmbuild for the users to set up the config directories.

I hope this helps.

Note You need to log in before you can comment on or make changes to this bug.