Bug 857168 - configure error with postgres
configure error with postgres
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-configure (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity urgent
: rc
: ---
Assigned To: Mo Morsi
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-13 13:48 EDT by Dave Johnson
Modified: 2012-12-04 10:19 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In the pg_hba.conf file, aeolus-configure changed the authentication method for each entry to md5. This caused aeolus-configure to fail when accessing the PostgreSQL database via Unix-domain sockets. This fix skips the "local" connections and sets only the "host" or "hostssl" methods to md5. aeolus-configure now interacts with PostgreSQL without error.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:19:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Johnson 2012-09-13 13:48:00 EDT
Description of problem:
=====================================================
configure error in latest downstream configure rpm


err: /Stage[main]/Postgres::Server/Service[postgresql]: Failed to call refresh: Could not restart Service[postgresql]: Execution of '/sbin/service postgresql restart' returned 1:  at /usr/share/aeolus-configure/modules/postgres/manifests/server.pp:17
notice: /Stage[main]/Aeolus::Conductor/Postgres::User[aeolus]/Exec[create_aeolus_postgres_user]/returns: could not change directory to "/root"
notice: /Stage[main]/Aeolus::Conductor/Postgres::User[aeolus]/Exec[create_aeolus_postgres_user]/returns: Password for user postgres: 
notice: /Stage[main]/Aeolus::Conductor/Postgres::User[aeolus]/Exec[create_aeolus_postgres_user]/returns: psql: fe_sendauth: no password supplied
err: /Stage[main]/Aeolus::Conductor/Postgres::User[aeolus]/Exec[create_aeolus_postgres_user]/returns: change from notrun to 0 failed: su postgres -c "psql postgres postgres -c                          \"CREATE USER aeolus WITH PASSWORD 'v23zj59an' CREATEDB\"" returned 2 instead of one of [0] at /usr/share/aeolus-configure/modules/postgres/manifests/user.pp:7



Version-Release number of selected component (if applicable):
aeolus-configure.noarch 0:2.8.5-1.el6cf


How reproducible:  100%


Steps to Reproduce:
1.  install from downstream nightly
2.  aeolus-configure -p ec2, mock
3.
  
Actual results:


Expected results:


Additional info:
Comment 3 Dave Johnson 2012-09-13 14:04:16 EDT
# "local" is for Unix domain socket connections only
local   all         all                               md5
# IPv4 local connections:
host    all         all         127.0.0.1/32          md5
# IPv6 local connections:
host    all         all         ::1/128               md5
Comment 5 Steve Linabery 2012-09-14 10:35:09 EDT
644ed66a14e026bf39c88cc4931d3efe246f7bf6 on master
7968ece2df3880c21824d94c52345c04c37fd478 on 1.1

both in latest respective builds.
Comment 7 Dave Johnson 2012-09-17 13:04:52 EDT
Good to go using 2012-09-14.5 puddle
Comment 9 errata-xmlrpc 2012-12-04 10:19:06 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.