Bug 857171 - [UI] IE8 fixes on Login and Header
[UI] IE8 fixes on Login and Header
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Windows
unspecified Severity unspecified
: rc
: ---
Assigned To: Shveta
Rehana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-13 13:52 EDT by Brian McLaughlin
Modified: 2012-12-04 10:19 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cloud Engine's login page and header rendered incorrectly in Internet Explorer 8. This fix adds some additional style tweaks so that Internet Explorer 8 and above renders Cloud Engine the same as other browsers.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:19:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
IE9_login page (129.52 KB, image/png)
2012-10-12 13:00 EDT, Shveta
no flags Details
IE9_inside header (1.11 MB, image/png)
2012-10-12 13:00 EDT, Shveta
no flags Details

  None (edit)
Description Brian McLaughlin 2012-09-13 13:52:47 EDT
Description of problem: The Login page and in-app Header of Conductor are not rendering as expected.


Version-Release number of selected component (if applicable):


How reproducible: Visit the app in IE8.


Steps to Reproduce:
1. Navigate to Conductor in IE8
2. Note the Login page styling.
3. Login and view the in-app Header and it's styling.
  
Actual results:
The styling in IE8 is a jarring departure from the latest Firefox, Chrome and Safari styling on the Login page and in-app Header

Expected results:
The styling should degrade gracefully where IE8 does not support modern CSS approaches.

Additional info:
aeolus-all-0.13.0-0.20120821174506gitb251f59.fc17.noarch
aeolus-conductor-0.13.0-0.20120821174506gitb251f59.fc17.noarch
aeolus-conductor-daemons-0.13.0-0.20120821174506gitb251f59.fc17.noarch
aeolus-conductor-devel-0.13.0-0.20120821174506gitb251f59.fc17.noarch
aeolus-conductor-doc-0.13.0-0.20120821174506gitb251f59.fc17.noarch
aeolus-configure-2.8.0-0.20120913093127git0b3dad6.fc17.noarch
rubygem-aeolus-cli-0.7.0-0.20120913093136git8a46b3f.fc17.noarch
rubygem-aeolus-image-0.6.0-0.20120913093130git902c81c.fc17.noarch
Comment 2 Matt Wagner 2012-09-13 14:46:28 EDT
The fix was Brian's, but I just cherry-picked both of them over to 1.1:

commit bcb597f65eba0439c84728a293e9b618c771ee6c
Author: Brian McLaughlin <bmclaugh@redhat.com>
Date:   Wed Sep 12 13:37:39 2012 -0400

    Header tweaks for IE8
    
    Signed-off-by: Matt Wagner <matt.wagner@redhat.com>
    (cherry picked from commit 978a18430cf5f2c0a880fe01035502bd7c3d5612)

commit 6a5fc5dbf3c55d972db36f8771553b48f852b46d
Author: Brian McLaughlin <bmclaugh@redhat.com>
Date:   Wed Sep 12 13:37:38 2012 -0400

    Login tweaks for IE8
    
    Signed-off-by: Matt Wagner <matt.wagner@redhat.com>
    (cherry picked from commit 69901cc55352d2dd0cc735fb3e6ea27a342f270e)
Comment 4 Shveta 2012-10-12 13:00:12 EDT
Created attachment 626129 [details]
IE9_login page

Login page looks same as in Firefox


rpm -qa|grep aeolus
aeolus-conductor-0.13.18-1.el6cf.noarch
aeolus-configure-2.8.9-1.el6cf.noarch
aeolus-configserver-0.4.11-1.el6cf.noarch
aeolus-all-0.13.18-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-daemons-0.13.18-1.el6cf.noarch
aeolus-conductor-doc-0.13.18-1.el6cf.noarch
rubygem-aeolus-cli-0.7.4-1.el6cf.noarch
Comment 5 Shveta 2012-10-12 13:00:47 EDT
Created attachment 626130 [details]
IE9_inside header
Comment 7 errata-xmlrpc 2012-12-04 10:19:09 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.