Bug 857255 - Info command can't find file for Gnu Debugger.
Info command can't find file for Gnu Debugger.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gdb (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jan Kratochvil
Fedora Extras Quality Assurance
:
Depends On: 844675
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-13 19:15 EDT by Dale Snell
Modified: 2012-10-01 12:58 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-14 01:07:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dale Snell 2012-09-13 19:15:02 EDT
Description of problem:
"info gdb" does not bring up the info file for the Gnu Debugger (gdb).  Rather, it brings up the file for the Gnu Database Manager (gdbm).  The man page for gdb is still there, but it doesn't cover everything the info file does.  For a gdb tyro like me, this is a definite handicap.

Note that "info gdbm" also brings up the file for the Gnu Database Manager, which I assume is correct.

Version-Release number of selected component (if applicable):
7.4.50.20120120-50.fc17

How reproducible:
Every time.

Steps to Reproduce:
1. Type  info gdb  in command line
2.
3.
  
Actual results:
Info brings up the Gnu Database Manager file

Expected results:
Info brings up the Gnu Debugger file.


Additional info:
This is on an x86_64 system, if that makes any difference.
Comment 1 Jan Kratochvil 2012-09-14 01:07:31 EDT
yum install gdb-doc
Comment 2 Pedro Alves 2012-09-14 04:50:50 EDT
Dale, for completeness, the reason "info gdb" was bringing up the Gnu Database Manager, is because "info" tries to be smart enought to understand what you meant with just a prefix of the menu entry you wanted, amongst the docs installed.

Thanks.
Comment 3 Steve Tyler 2012-10-01 12:36:56 EDT
Before installing gdb-doc, I got the gdb man page with this:
$ info gdb

The man page says:

SEE ALSO
       `gdb' entry in info; Using GDB: A Guide to the GNU Source-Level  Debug‐
       ger, Richard M. Stallman and Roland H. Pesch, July 1991.

That could be more explicit by saying that full documentation for gdb is available as info, pdf, and html files. Here is what the "ls" man page says:

$ man ls
...
SEE ALSO
       The  full  documentation  for  ls is maintained as a Texinfo manual.  If the info and ls programs are
       properly installed at your site, the command

              info coreutils 'ls invocation'

       should give you access to the complete manual.

$ rpm -qa 'gdb*' | sort
gdb-7.4.50.20120120-50.fc17.x86_64
gdbm-1.10-2.fc17.x86_64

$ rpm -qd gdb
/usr/share/doc/gdb-7.4.50.20120120/COPYING
/usr/share/doc/gdb-7.4.50.20120120/COPYING.LIB
/usr/share/doc/gdb-7.4.50.20120120/COPYING3
/usr/share/doc/gdb-7.4.50.20120120/NEWS
/usr/share/doc/gdb-7.4.50.20120120/README
/usr/share/man/man1/gdb.1.gz
/usr/share/man/man1/gstack.1.gz
/usr/share/man/man1/pstack.1.gz

$ rpm -qd gdbm
/usr/share/doc/gdbm-1.10/AUTHORS
/usr/share/doc/gdbm-1.10/COPYING
/usr/share/doc/gdbm-1.10/NEWS
/usr/share/doc/gdbm-1.10/NOTE-WARNING
/usr/share/doc/gdbm-1.10/README
/usr/share/doc/gdbm-1.10/THANKS

$ sudo yum install gdb-doc
...
$ rpm -ql gdb-doc
/usr/share/doc/gdb-doc-7.4.50.20120120
/usr/share/doc/gdb-doc-7.4.50.20120120/annotate.html
/usr/share/doc/gdb-doc-7.4.50.20120120/annotate.pdf
/usr/share/doc/gdb-doc-7.4.50.20120120/gdb.html
/usr/share/doc/gdb-doc-7.4.50.20120120/gdb.pdf
/usr/share/info/annotate.info.gz
/usr/share/info/gdb.info.gz
Comment 4 Pedro Alves 2012-10-01 12:49:25 EDT
Thanks Dave,

I agree, and that's why I did exactly that upstream shortly after your report:

http://sourceware.org/ml/gdb-patches/2012-09/msg00276.html

:-)

I failed to tell you about it then; sorry about that.
Comment 5 Steve Tyler 2012-10-01 12:58:31 EDT
(In reply to comment #4)
> Thanks Dave,
> 
> I agree, and that's why I did exactly that upstream shortly after your
> report:
> 
> http://sourceware.org/ml/gdb-patches/2012-09/msg00276.html
> 
> :-)
> 
> I failed to tell you about it then; sorry about that.

Thanks, Pedro. That's excellent.

Note You need to log in before you can comment on or make changes to this bug.