This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 857362 - base64 -d chokes on its own output
base64 -d chokes on its own output
Status: CLOSED DUPLICATE of bug 719317
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: coreutils (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Ondrej Vasik
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-14 04:41 EDT by Matej Kollar
Modified: 2015-07-26 18:21 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-14 05:06:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matej Kollar 2012-09-14 04:41:52 EDT
Description of problem: base64 -d fails with "base64: invalid input".
after few bytes.

Version-Release number of selected component (if applicable):

> # rpm -q coreutils
> coreutils-5.97-34.el5_8.1
> # base64 --version
> base64 (GNU coreutils) 5.97
> Copyright (C) 2006 Free Software Foundation, Inc.
> This is free software.  You may redistribute copies of it under the terms of
> the GNU General Public License <http://www.gnu.org/licenses/gpl.html>.
> There is NO WARRANTY, to the extent permitted by law.
> 
> Written by Simon Josefsson.

How reproducible: always/deterministic


Steps to Reproduce:

  1. just run
     seq 100 | base64 | base64 -d
  
Actual results:
  -d part dies after printing 22\n

Expected results:
  does not choke

Additional info:
  # seq 100 | base64

  produces

  > MQoyCjMKNAo1CjYKNwo4CjkKMTAKMTEKMTIKMTMKMTQKMTUKMTYKMTcKMTgKMTkKMjAKMjEKMjIK
  > MjMKMjQKMjUKMjYKMjcKMjgKMjkKMzAKMzEKMzIKMzMKMzQKMzUKMzYKMzcKMzgKMzkKNDAKNDEK
  > NDIKNDMKNDQKNDUKNDYKNDcKNDgKNDkKNTAKNTEKNTIKNTMKNTQKNTUKNTYKNTcKNTgKNTkKNjAK
  > NjEKNjIKNjMKNjQKNjUKNjYKNjcKNjgKNjkKNzAKNzEKNzIKNzMKNzQKNzUKNzYKNzcKNzgKNzkK
  > ODAKODEKODIKODMKODQKODUKODYKODcKODgKODkKOTAKOTEKOTIKOTMKOTQKOTUKOTYKOTcKOTgK
  > OTkKMTAwCg==

  which can be perfectly normally decoded on RHEL6 machine with
  base64 (GNU coreutils) 8.4

:-(
Comment 1 Kamil Dudka 2012-09-14 05:06:46 EDT

*** This bug has been marked as a duplicate of bug 719317 ***

Note You need to log in before you can comment on or make changes to this bug.