Bug 857378 - RHEV-H create Volume group should only on user selected disk.
RHEV-H create Volume group should only on user selected disk.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
x86_64 All
high Severity high
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-14 05:07 EDT by cshao
Modified: 2016-04-26 10:09 EDT (History)
12 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-5.el6
Doc Type: Bug Fix
Doc Text:
Previously, Red Hat Enterprise Virtualization Hypervisor created the hostvg not on the user-selected disk and on the booting disk. This was caused by logic error in parsing the available disks to be used during installation. This fix instructs the installer not to create the HOSTVG on the boot disk unless the user has explicitly directed it.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:38:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ovirt.log (96.90 KB, text/plain)
2012-09-14 05:08 EDT, cshao
no flags Details
vg pic (185.71 KB, image/jpeg)
2012-09-14 05:09 EDT, cshao
no flags Details

  None (edit)
Description cshao 2012-09-14 05:07:36 EDT
Description of problem:
RHEV-H create Volume group should only on user selected disk, but actually, it will create VG on user selected disk and booting disk.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20120910.0.rhev31.el6_3

How reproducible:
100%

Steps to Reproduce:
1. Boot from PXE and install RHEV-H.
2. Select hard disk to use for booting RHEV-H.
3. Select USB device to use for installation of RHEV-H.
4. Finish the installation process.
  
Actual results:
1. RHEV-H create Volume group on user selected disk and booting disk.

# pvs
  PV                                            VG     Fmt  Attr PSize   PFree
  /dev/mapper/1ATA_ST500DM002-1BD142_Z2ASNRMFp4 HostVG lvm2 a--  465.04g    0 
  /dev/mapper/1SanDiskp1                        HostVG lvm2 a--   14.91g    0 

===================
pvcreate -ff -y "/dev/mapper/1ATA_ST500DM002-1BD142_Z2ASNRMFp4"
2012-09-14 07:27:58,793 - DEBUG - ovirtfunctions -   Physical volume "/dev/mapper/1ATA_ST500DM002-1BD142_Z2ASNRMFp4" successfully created

2012-09-14 07:27:58,793 - INFO - storage - Creating volume group on /dev/mapper/1ATA_ST500DM002-1BD142_Z2ASNRMFp4
2012-09-14 07:27:59,043 - DEBUG - ovirtfunctions - vgcreate /dev/HostVG "/dev/mapper/1ATA_ST500DM002-1BD142_Z2ASNRMFp4"
2012-09-14 07:27:59,043 - DEBUG - ovirtfunctions -   Volume group "HostVG" successfully created

pvcreate -ff -y "/dev/mapper/1SanDiskp1"
2012-09-14 07:28:03,624 - DEBUG - ovirtfunctions -   Physical volume "/dev/mapper/1SanDiskp1" successfully created

2012-09-14 07:28:03,624 - INFO - storage - Extending volume group on /dev/mapper/1SanDiskp1
2012-09-14 07:28:03,916 - DEBUG - ovirtfunctions - vgextend /dev/HostVG "/dev/mapper/1SanDiskp1"
2012-09-14 07:28:03,917 - DEBUG - ovirtfunctions -   Volume group "HostVG" successfully extended


Expected results:
RHEV-H create Volume group should only on user selected disk.

Additional info:
Comment 1 cshao 2012-09-14 05:08:45 EDT
Created attachment 612779 [details]
ovirt.log
Comment 2 cshao 2012-09-14 05:09:28 EDT
Created attachment 612783 [details]
vg pic
Comment 10 errata-xmlrpc 2013-02-28 11:38:50 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.