Bug 857388 - HP deskjet 6940 garbled print
HP deskjet 6940 garbled print
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-14 05:54 EDT by Bob Goodwin
Modified: 2012-09-20 04:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-20 04:32:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
this is the troubleshoot.txt file produced by following the instructions in the webpage you pointed to. (240.84 KB, text/plain)
2012-09-17 18:40 EDT, Bob Goodwin
no flags Details
/var/log/messages during troubleshooting test page print (13.94 KB, text/plain)
2012-09-19 06:02 EDT, Bob Goodwin
no flags Details
New troubleshoot.txt from 'test' hplip (171.91 KB, text/plain)
2012-09-19 06:09 EDT, Bob Goodwin
no flags Details

  None (edit)
Description Bob Goodwin 2012-09-14 05:54:43 EDT
Description of problem:
HP Deskjet 6940 printer does not print or produces garbled print. This printer worked correctly under Fedora 14. The printer is connected by ethernet through a second NIC card using a dedicated IP address and 'ifconfig' shows no transfer errors during processing.

HPLIP does not see this printer automatically during configure and I have to manually specify it's IP address for HPLIP to find and configure the printer. This was the same in Fedora 14. This printer has internal web pages and access to these web pages from a browser is error free. A full page test print initiated from the printer's control panel works correctly.

The printer is currently configured by hplip version 3.12.9. This is an upgrade from the official Fedora version 3.12.6 which exhibited this same behavior. The upgrade didn't help but appears to work as far as configuring the printer. Results of printing are the same as with the fc17 version.

The error log; /var/log/cups/error.log reports; gstoraster failed. Then reports 'stopped unresponsive printer'.

Version-Release number of selected component (if applicable):
cups-1.5.4-2.fc17.x86_64
hplip-3.12.6.1.fc17
hplip-3.12.9 (from HP website)

How reproducible:
always.

Steps to Reproduce:
1.Select print option from a pdf or doc viewer.
2.
3.
  
Actual results:
There is a long delay before printing begins. Results are random. Mostly prints first few lines and then ejects or prints garbled bits from the original document.


Expected results:
Under Fedora 14 I regularly printed the pdf musical scores for my classical guitar lessons.

Additional info:
I have gone through the usual gyrations of uninstalling and reinstalling software and device configurations with no change.
Comment 1 Tim Waugh 2012-09-17 07:45:41 EDT
Please follow the troubleshooting procedure outlined here:
https://fedoraproject.org/wiki/How_to_debug_printing_problems#Printing_troubleshooter

You should end up with a troubleshoot.txt file which you should attach to this bug report.
Comment 2 Bob Goodwin 2012-09-17 18:40:47 EDT
Created attachment 613807 [details]
this is the troubleshoot.txt file produced by following the instructions in the webpage you pointed to.

The 'test page' was used for this test. The HP Device manager Showed the printer status as 'job started. Six minutes later it posted an 'idle' status, six minutes after that it posted a 'job continuing' status but the printer never actually did anything.
Comment 3 Tim Waugh 2012-09-18 05:04:53 EDT
The hp backend stopped with a SIGPIPE signal:

D [17/Sep/2012:17:57:58 -0400] PID 2595 (/usr/lib/cups/backend/hp) did not catch or ignore signal 13.

Can you see anything in /var/log/messages around that time from hp?
Comment 4 Jiri Popelka 2012-09-18 07:10:27 EDT
(In reply to comment #3)
> Can you see anything in /var/log/messages around that time from hp?

I've made a scratch-build with debug messages in hp backend enabled.
http://koji.fedoraproject.org/koji/taskinfo?taskID=4498017
Can you try that, Bob ?

I just uncommented #define HP_DEBUG in prnt/backend/hp.c
Hope it's everything we need to do to see the debug messages.
I know there can be set hpLogLevel in cupsd.conf but that's AFAICT no related to these backend debug messages.
Comment 5 Bob Goodwin 2012-09-19 06:02:18 EDT
Created attachment 614297 [details]
/var/log/messages during troubleshooting test page print

yum erased the original hplip files and rpm installed your debug files.

Ran system-config-printer->help->troubleshoot->print-test-page

These are the log file messages during that time.

I will also attach the troubleshoot.txt file

Best regards,
Bob G.
Comment 6 Bob Goodwin 2012-09-19 06:09:06 EDT
Created attachment 614299 [details]
New troubleshoot.txt from 'test' hplip
Comment 7 Jiri Popelka 2012-09-19 06:50:24 EDT
(In reply to comment #5)
> /var/log/messages during troubleshooting test page print

I'm glad it (debug messages) works.

Sep 19 05:09:12 localhost hp[2224]: io/hpmud/jd.c 561: timeout write_channel hp:/net/Deskjet_6940_series?ip=169.254.78.213
Sep 19 05:21:11 localhost hp[2224]: io/hpmud/jd.c 567: unable to write_channel: Connection timed out hp:/net/Deskjet_6940_series?ip=169.254.78.213

Can you create a new printer queue (for example with system-config-printer) using the 'AppSocket/HP JetDirect' backend and print something? That way we'll know if that's really a hp backend problem or some other network communication problem. Thanks.
Comment 8 Bob Goodwin 2012-09-19 12:32:26 EDT
Sorry to switch horses in the middle of a race but I received the network hub I ordered last week and installed it; putting both the internet modem and the printer on the motherboard's ethernet connection. The printer is now functioning normally. I removed the network card from my PC since it's no longer needed.

Just to repeat a point,the dual NIC lash-up worked fine under FC14. I'm sure the second NIC was functioning because I could access the printers built-in web pages and printing actually did start sometimes and the first few lines were correct. Also 'ifconfig' showed no signs of data transfer errors on the second NIC.
Comment 9 Jiri Popelka 2012-09-20 04:32:21 EDT
No problem.
I doubt we are able to investigate the previous problem any further, closing then. I'm happy it works now.

Note You need to log in before you can comment on or make changes to this bug.