Bug 857402 - NFS client hangs and can't re-establish communication with NFS server
NFS client hangs and can't re-establish communication with NFS server
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.3
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: nfs-maint
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-14 06:28 EDT by Thomas
Modified: 2012-10-18 12:42 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-18 12:42:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
wireshark packet capture data (33.47 KB, application/octet-stream)
2012-09-14 06:28 EDT, Thomas
no flags Details
RPC debug file (21.00 KB, text/plain)
2012-09-14 06:29 EDT, Thomas
no flags Details

  None (edit)
Description Thomas 2012-09-14 06:28:39 EDT
Created attachment 612794 [details]
wireshark packet capture data

Description of problem:

On normal activity, the NFS client hangs and can't re-establish communication with our NFS server (Netapp filer FAS2050).
the MNT operation is successful. The client fails on ‘fsinfo’ call. It attempts to reuse existing socket to connect to 2049 port on NFS server. It fails there. As a result it even doesn’t try to establish TCP connection with the NFS server (to port 2049).

Version-Release number of selected component (if applicable):

Name        : nfs-utils
Arch        : x86_64
Epoch       : 1
Version     : 1.2.3
Release     : 26.el6

How reproducible:

Not reproducible. The problem is totally Aleatory.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Thomas 2012-09-14 06:29:56 EDT
Created attachment 612795 [details]
RPC debug file
Comment 3 Thomas 2012-10-18 12:15:54 EDT
NFS uses a random port (from 665 to 1023) to communicate between the client and the server.
There was a very old ACL rule implemented on the switch between the server subnet and the client subnet
This rule filtered tcp port 707
The rule has been removed, no crash since this ACL modification.
Comment 4 Ric Wheeler 2012-10-18 12:42:43 EDT
Sounds like we can close this as not a bug. Please reopen if I misunderstand. 

thanks!

Note You need to log in before you can comment on or make changes to this bug.