Bug 857422 - display more information in About dialog of windows version
display more information in About dialog of windows version
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer (Show other bugs)
3.1.0
Unspecified Windows
unspecified Severity medium
: ---
: ---
Assigned To: Marc-Andre Lureau
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-14 07:30 EDT by David Jaša
Modified: 2012-10-30 14:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-30 14:39:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2012-09-14 07:30:12 EDT
Description of problem:
display more information in About dialog of windows version

Such information useful for debugging would be:
  * revision, in addition to version (0.5.3-11 for instance instead of 0.5.3)
  * spice-gtk version
  * architecture (x32 and x64 to follow windows habits)
  * usbclerk and/or old usb redirector versions and status if USB share
    is enabled
  * possibly also build date or ID (this is also in binary and process
    properties)

Version-Release number of selected component (if applicable):
3.1 beta1 build
Comment 1 David Jaša 2012-09-14 07:32:14 EDT
For clarification, this applies just to Windows versions where some of the info is harder to find than on RHEL.
Comment 3 Marc-Andre Lureau 2012-10-11 15:34:34 EDT
it's not so easy.. extracting revision of dependencies during build time is almost mission impossible today.

* architecutre, version and revision of deps are already part of the $prefix/deps file
* I guess we could obtain usbclerck status somehow, but I am not sure that would be so helpful if you can't manage it
* build date could be added to deps file

We need to redefine the needed information. Eventually the deps file could be cleaned up a little and opened/shown in the about dialog.
Comment 4 Marc-Andre Lureau 2012-10-29 09:27:11 EDT
David, is the $installprefix/deps.txt file enough for now?
Comment 5 David Jaša 2012-10-29 09:29:34 EDT
Looks good, thanks for the pointer. BTW could the file use crlf line endings so that it can be displayed fine just with notepad?
Comment 6 Marc-Andre Lureau 2012-10-29 09:46:26 EDT
(In reply to comment #5)
> Looks good, thanks for the pointer. BTW could the file use crlf line endings
> so that it can be displayed fine just with notepad?

it is already, perhaps you are using an older version.
Comment 7 Marc-Andre Lureau 2012-10-30 14:39:11 EDT
closing as worksforme, since requested information are available already in deps.txt

Note You need to log in before you can comment on or make changes to this bug.