Bug 857427 - Wrong status displayed for "conductor-delayed_job" service on rhel
Wrong status displayed for "conductor-delayed_job" service on rhel
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-configure (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity medium
: beta2
: ---
Assigned To: Mike Orazi
Rehana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-14 07:37 EDT by Aziza Karol
Modified: 2012-12-04 10:19 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The conductor-delayed_job service incorrectly displayed as "stopped" when running. This bug fix corrects the status of conductor-delayed_job as "running".
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:19:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aziza Karol 2012-09-14 07:37:23 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.install aeolus and run aeolus-configure
2.check aeolus-check-services 

  
Actual results:
#aeolus-check-services | grep delayed_job
Checking conductor-delayed_job ...
 FAILURE: delayed_job is stopped

I  tried starting the service
#service  conductor-delayed_job start
Starting conductor-delayed_job: Using gem require instead of bundler
/usr/share/aeolus-conductor/app/util/deployable_xml.rb:210: warning: already initialized constant DEPLOYABLE_VERSION
ERROR: there is already one or more instance(s) of the program running
ERROR: there is already one or more instance(s) of the program running
[  OK  ]

#ps auxf|grep dela
root     25665  0.0  0.0 103300   828 pts/1    S+   07:34   0:00          \_ grep dela
aeolus   24959  0.1  2.8 251516 111500 ?       S    07:21   0:00 delayed_job.0                                                                                       
aeolus   24961  0.1  2.8 251516 111500 ?       S    07:21   0:00 delayed_job.1                                                                                       
#service  conductor-delayed_job status
delayed_job is stopped

"conductor-delayed_job" service is still shown as stopped.


Expected results:
should display correct status.


Additional info:
rpm -qa | grep aeolus
aeolus-conductor-doc-0.13.6-1.el6cf.noarch
aeolus-configure-2.8.6-1.el6cf.noarch
rubygem-aeolus-image-0.6.0-1.el6cf.noarch
aeolus-conductor-daemons-0.13.6-1.el6cf.noarch
aeolus-conductor-0.13.6-1.el6cf.noarch
aeolus-all-0.13.6-1.el6cf.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
Comment 2 Steve Linabery 2012-09-14 17:07:57 EDT
in aeolus-conductor-0.13.8-1
Comment 4 Steve Linabery 2012-09-18 14:17:57 EDT
yeah, setting this to ON_QA since it's attached in ET and the build is correct in puddle.
Comment 5 Ronelle Landy 2012-09-20 10:38:18 EDT
Verified that the incorrect status reproting is fixed in:

>> rpm -qa |grep aeolus
aeolus-configure-2.8.6-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-conductor-0.13.8-1.el6cf.noarch
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch
aeolus-all-0.13.8-1.el6cf.noarch

Test output is included below:

>>  aeolus-check-services

Checking mongod ...
 Success: mongod (pid 24889) is running...

Checking iwhd ...
 Success: iwhd (pid  24913) is running...

Checking postgresql ...
 Success: postmaster (pid  24952) is running...

Checking httpd ...
 Success: httpd (pid  24973) is running...

Checking deltacloud-core ...
 Success: deltacloud-core (pid  25007) is running...

Checking libvirtd ...
 Success: libvirtd (pid  25025) is running...

Checking aeolus-conductor ...
 Success: thin (pid  25110) is running...

Checking conductor-delayed_job ...
 FAILURE: delayed_job.0 is stopped
delayed_job.1 is stopped

Checking conductor-dbomatic ...
 Success: dbomatic (pid  25160) is running...

Checking imagefactory ...
 Success: imagefactory (pid  25177) is running...

Checking ntpd ...
 Success: ntpd (pid  25194) is running...

Note that the conductor-delayed_job service is stopped. Starting service ...

>>  service conductor-delayed_job start
Starting conductor-delayed_job: Using gem require instead of bundler
/usr/share/aeolus-conductor/config/../app/util/deployable_xml.rb:210: warning: already initialized constant DEPLOYABLE_VERSION
delayed_job.0: process with pid 25515 started.
delayed_job.1: process with pid 25517 started.

Service status is correctly reported ....

>> service conductor-delayed_job status
delayed_job.0 (pid  25515) is running...
delayed_job.1 (pid  25517) is running...
Comment 7 errata-xmlrpc 2012-12-04 10:19:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.