Bug 857442 - [remote-viewer] Ctrl+shift+Q works just with one display
[remote-viewer] Ctrl+shift+Q works just with one display
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-14 08:50 EDT by Tomas Jamrisko
Modified: 2012-10-15 03:36 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-15 03:36:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Jamrisko 2012-09-14 08:50:24 EDT
Description of problem:
When connected to a guest (windows 7) with more than one display, Ctrl+shift+Q only works with one window of remote-viewer

Version-Release number of selected component (if applicable):
virt-viewer-0.5.3-1.el7
virt-viewer-0.5.2.-9.el6

How reproducible:
Always 


Steps to Reproduce:
1. Connect to the guest
2. Open at least two display channels
3. Ctrl+shift+q in the remote-viewer window with highest display number

Actual results:
Nothing happens

Expected results:
The window gets closed? 

Additional info:
Clicking Quit closes all windows from the session regardless of the window it was invoked from
Comment 2 Geyang Kong 2012-10-15 00:40:11 EDT
Maybe I misunderstood your meaning, but I cannot reproduce this bug. I noticed you said: Ctrl+shift+q "in" the remote-viewer window. Of course nothing will happen in this case. Since you've sent Ctrl+shift+q to the guest, not remote-viewer. When I release the mouse pointer from guest(such as moving pointer to title bar), then press Ctrl+shift+q, window will be closed.

My build is:
virt-viewer-0.5.2.-9.el6

Note You need to log in before you can comment on or make changes to this bug.