Bug 857470 - Unable to upgrade fedore 17 to fedora 18 using yum
Unable to upgrade fedore 17 to fedora 18 using yum
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-14 10:07 EDT by Mile Davidovic
Modified: 2014-01-21 18:23 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-14 12:01:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mile Davidovic 2012-09-14 10:07:43 EDT
Description of problem:
Unable to upgrade Fedore.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpm --import https://fedoraproject.org/static/DE7F38BD.txt
2. yum update yum
3. yum clean all
4. yum --releasever=18 --disableplugin=presto distro-sync
  
Actual results:
Transaction Check Error:
  file /usr/share/myspell/en_US.dic from install of hunspell-en-0.20110318-6.fc18.noarch conflicts with file from package hunspell-en-US-0.20110318-8.fc17.noarch
  file /usr/lib/python2.7/site-packages/IPython/__init__.py from install of python-ipython-console-0.13-4.fc18.noarch conflicts with file from package ipython-0.12-3.fc17.noarch
  file /usr/lib/python2.7/site-packages/IPython/config/__init__.py from install of python-ipython-console-0.13-4.fc18.noarch conflicts with file from package ipython-0.12-3.fc17.noarch


Expected results:


Additional info:
Comment 1 Tim Lauridsen 2012-09-14 10:18:54 EDT
It is not a supported way of upgrading to new fedora release

It can be done

http://fedoraproject.org/wiki/Upgrading_Fedora_using_yum

But you have to be able solve problem with packages there is incompatible.

This is not yum's problem 

Try to delete the conflicting packages before updating, if you can
Comment 2 Mile Davidovic 2012-09-14 10:32:18 EDT
Hi,
steps from 1-4 are taken from http://fedoraproject.org/wiki/Upgrading_Fedora_using_yum.

Just for your information list of conflicting packages includes: firefox, eclipse, gnome-shell, control-center ...
Comment 3 Tim Lauridsen 2012-09-14 12:01:11 EDT
There is nothing the yum developers can do about it.
Add this procedure is not supported by the Fedora Project, so you are on you own
Sorry.

Note You need to log in before you can comment on or make changes to this bug.