Bug 857661 - lost multicast packets with RTL8111F
lost multicast packets with RTL8111F
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-15 14:04 EDT by Lukas Middendorf
Modified: 2013-03-12 17:02 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-12 17:02:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
packet capture (in promiscuous mode) of one packet of a working stream and one packet of a not working stream (2.73 KB, application/octet-stream)
2012-09-15 14:04 EDT, Lukas Middendorf
no flags Details

  None (edit)
Description Lukas Middendorf 2012-09-15 14:04:15 EDT
Created attachment 613308 [details]
packet capture (in promiscuous mode) of one packet of a working stream and one packet of a not working stream

Description of problem:

I have various ipv4 multicast rtp streams provided by my Internet provider (German Telekom).
Every stream has an url like rtp://@239.35.10.1:10000 with differences just in the last block of the address. The DSL router properly routes the multicast groups I have subscribed to.
I can watch the streams with vlc.

The problem is that only some streams work out of the box.
Some streams work reliably, like
rtp://@239.35.10.7:10000
rtp://@239.35.10.53:10000
others reliably fail to work like
rtp://@239.35.10.54:10000
rtp://@239.35.10.4:10000

For the failing cases the multicast groups are joined properly as can be seen with "netstat -g". The packets are properly forwarded by the router (blinking LED at the network interface). The multicast packets do not seem to reach the kernel as nothing shows up in wireshark (not in promiscuous mode). When the network interface is put into promiscuous mode or allmulti mode, then all streams work (and packets can be seen in wireshark). Iptables firewall is disabled. The same streams work properly on my notebook in the same network.

So there seems to be a problem with the multicast packet filtering in the network chip (or in the driver).

My network interface is a RTL8111F which is identified by lspci as
Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 09)

I don't know if this is a bug in the hardware or in the driver, but it should either be fixed or worked around by activating allmulti by default.


Version-Release number of selected component (if applicable):
kernel-3.5.3-1.fc17.x86_64

How reproducible:
always
Comment 1 Josh Boyer 2013-03-12 16:26:53 EDT
Are you still seeing this with 3.7.9 or 3.8.2 in updates-testing?
Comment 2 Lukas Middendorf 2013-03-12 16:53:37 EDT
Seems to be fixed with 3.7.9-104.fc17.x86_64
Comment 3 Josh Boyer 2013-03-12 17:02:59 EDT
Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.