Bug 857668 - Scenery files missing
Scenery files missing
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: FlightGear-data (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fabrice Bellet
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-15 14:50 EDT by Zenon Panoussis
Modified: 2012-09-18 12:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-18 12:07:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Script to create scenery rpms (577 bytes, text/plain)
2012-09-15 14:53 EDT, Zenon Panoussis
no flags Details
.spec template needed by script (926 bytes, text/plain)
2012-09-15 14:54 EDT, Zenon Panoussis
no flags Details
Replaces previous attachments (1.04 KB, application/x-tar)
2012-09-15 18:29 EDT, Zenon Panoussis
no flags Details

  None (edit)
Description Zenon Panoussis 2012-09-15 14:50:20 EDT
FlightGear-data only contains one quadrangle of scenery, and rightly so. The remaining world scenery should be packaged separately, but is currently not available in rpms. The attached files fix this.
Comment 1 Zenon Panoussis 2012-09-15 14:53:05 EDT
Created attachment 613331 [details]
Script to create scenery rpms

Meant to run in the rpmbuild/SPECS directory.
Comment 2 Zenon Panoussis 2012-09-15 14:54:01 EDT
Created attachment 613332 [details]
.spec template needed by script
Comment 3 Zenon Panoussis 2012-09-15 18:29:59 EDT
Created attachment 613360 [details]
Replaces previous attachments

Tinkered a bit with the script and the template to 
- prevent re-downloading already downloaded sceneries
- allow adding to an already existing changelog
- fix a silly typo in %description
- do a teeny-weeny bit of error checking
Comment 4 Fabrice Bellet 2012-09-18 12:07:51 EDT
Thanks for your work Zenon! That will probably interest other people that prefer to have some scenary files pre-packaged. However, I won't push these packages in Fedora for several reasons : 1/ the size! the whole world scenaries represent a huge amount of data, 2/ automatically generated packages are discouraged because hard to maintain individually, and 3/ there're alternatives to gather other scenary files than the San Francisco area.

fgrun can work nicely with terrasync, and fetch scenery files on-demand while flightgear is running, depending on the flight location. And maybe more simple, recent FlightGear version has this feature built-in (Environment->Scenery Download).

Note You need to log in before you can comment on or make changes to this bug.