Bug 857777 - error updating Python in Fedora 16
error updating Python in Fedora 16
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-16 21:26 EDT by Bill Campbell
Modified: 2014-01-21 18:23 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 00:37:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Software update window showing the 4 packages that cause this error (46.29 KB, image/png)
2012-09-16 21:26 EDT, Bill Campbell
no flags Details
screenshot of update window with the 4 packages that cause the error (46.29 KB, image/png)
2012-09-16 21:28 EDT, Bill Campbell
no flags Details

  None (edit)
Description Bill Campbell 2012-09-16 21:26:57 EDT
Created attachment 613547 [details]
Software update window showing the 4 packages that cause this error

Description of problem:

ERROR with transaction check vs depsolve:
python(abi) = 2.6 is needed by alchemist-1.0.37-8.fc12.i686
python-abi = 2.6 is needed by alchemist-1.0.37-8.fc12.i686
Please report this error at https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum


Version-Release number of selected component (if applicable):


How reproducible:

run software update - every run gives this result.


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bill Campbell 2012-09-16 21:28:25 EDT
Created attachment 613549 [details]
screenshot of update window with the 4 packages that cause the error
Comment 2 Bill Campbell 2012-09-16 21:29:52 EDT
first time sending a bug report in - sorry for the duplicate attachments.
Comment 3 Tim Lauridsen 2012-09-17 00:37:37 EDT
The problem is that you have a old version of alchemist-1.0.37-8.fc12.i686 installed, there need python-2.6, so it blocks the update to python-2.7.

yum remove alchemist (as root)

then the system should be able to update.

After that your can find a more recent version of alchemist and install it, if it is something you need

Note You need to log in before you can comment on or make changes to this bug.