Bug 857791 - DHT: Always return the latest post/pre time in stats for directories
DHT: Always return the latest post/pre time in stats for directories
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: distribute (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: shishir gowda
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-16 22:59 EDT by shishir gowda
Modified: 2013-12-08 20:33 EST (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:27:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shishir gowda 2012-09-16 22:59:49 EDT
Description of problem:
Since Directories are spread across subvol's, and each subvol's dir time stamps(a/c/mtime) can be updated independently, we need to return the latest times to keep it cache friendly

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 shishir gowda 2012-10-11 01:51:12 EDT
Fix sent for review (http://review.gluster.org/#change,3737).
Ran sanity(posix compliance, dbench, iozone, areequal) successfully on 4 brick distribute, spread across 2 nodes.
Comment 2 Vijay Bellur 2012-10-16 17:27:26 EDT
CHANGE: http://review.gluster.org/3737 (cluster/distribute: Always return the latest time in struct iatt.) merged in master by Anand Avati (avati@redhat.com)

Note You need to log in before you can comment on or make changes to this bug.