Bug 857796 - [whql][netkvm][job-id-1048]PM_requirements failed on windows 8 64 bits
[whql][netkvm][job-id-1048]PM_requirements failed on windows 8 64 bits
Status: CLOSED DUPLICATE of bug 838002
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Yan Vugenfirer
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-16 23:25 EDT by Min Deng
Modified: 2012-09-19 09:16 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-19 09:16:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Min Deng 2012-09-16 23:25:15 EDT
Description of problem:
The job named PM_requirements failed on windows 8 64bits via HCK

Version-Release number of selected component (if applicable):

virtio-win-prewhql-0.1-35
kernel-2.6.32-302.el6.x86_64
qemu-kvm-0.12.1.2-2.307.el6.x86_64

How reproducible:
Tried 5 times and failed 5 times

Steps to Reproduce:
1.boot up guests with the following CLI
Guest1,
  /usr/libexec/qemu-kvm -m 6G -smp 4 -cpu cpu64-rhel6,+x2apic -usbdevice tablet -drive file=win8-64-nic1.raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=10:52:54:a6:19:41,bus=pci.0,addr=0x4,id=virtio-net-pci0 -netdev tap,sndbuf=0,id=hostnet1,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet1,mac=10:52:10:06:39:02,bus=pci.0,addr=0x5,id=virtio-net-pci1 -netdev tap,sndbuf=0,id=hostnet2,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet2,mac=10:52:1f:16:39:03,bus=pci.0,addr=0x6 -uuid f28951fe-3f81-476d-8afa-eb6fa55f258a -rtc base=localtime,clock=host,driftfix=slew -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-win8-64-nic1,server,nowait -mon chardev=111a,mode=readline -vnc :1 -bios /usr/share/seabios/bios-pm.bin -monitor stdio
Guest2,
 /usr/libexec/qemu-kvm -m 6G -smp 4 -cpu cpu64-rhel6,+x2apic -usbdevice tablet -drive file=win8-64-nic2.raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=10:52:1b:55:39:01,bus=pci.0,addr=0x4,id=virtio-net-pci0 -netdev tap,sndbuf=0,id=hostnet1,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet1,mac=10:52:aa:1b:01:52,bus=pci.0,addr=0x5 -uuid 04858bd4-ed9e-48b2-8262-167d2371fec7 -rtc base=localtime,clock=host,driftfix=slew -no-kvm-pit-reinjection -chardev socket,id=111b,path=/tmp/monitor-win8-64-nic2,server,nowait -mon chardev=111b,mode=readline -vnc :2 -bios /usr/share/seabios/bios-pm.bin -monitor stdio
2.submit the job to HCK
  
Actual results:The job failed due to the following error,
--------------------------------------------------------------------------------
Start Test 9/18/2012 1:12:38.626 AM Verify No-Pause-On-Suspend for Red Hat VirtIO Ethernet Adapter 
Error 9/18/2012 1:12:38.626 AM PCI\VEN_1AF4&DEV_1000&SUBSYS_00011AF4&REV_00 does not indicate support for No-Pause-On-Suspend. It is required for certification. 
File:    Line: 0 
Error Type:   WIN32 
Error Code:   0x88888 
Error Text:   Error 0x00088888 
End Test 9/18/2012 1:12:38.626 AM Verify No-Pause-On-Suspend for Red Hat VirtIO Ethernet Adapter 
Result:   Fail 
Repro:   C:\WLK\JobsWorkingDir\Tasks\WTTJobRun14CB8E7F-7D81-4C86-9685-BC7B87213878\ndistest.net\ndistest.exe /logo /auto /client /target:Miniport /tc:PCI\VEN_1AF4&DEV_1000&SUBSYS_00011AF4&REV_00\3&13C0B0C5&0&20 /jobs:lan\PM_Requirements.cpp 
--------------------------------------------------------------------------------

Expected results:
The job can passed

Additional info:
Comment 3 Yan Vugenfirer 2012-09-19 09:15:43 EDT
>> No-Pause-On-Suspend 

This is duplicated bug (https://bugzilla.redhat.com/show_bug.cgi?id=838002). Please close.

It can be verified only with driver build specifically for Windows 8.
Comment 4 Yan Vugenfirer 2012-09-19 09:16:06 EDT

*** This bug has been marked as a duplicate of bug 838002 ***

Note You need to log in before you can comment on or make changes to this bug.