Bug 857818 - Cannot run player
Cannot run player
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: player (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Tim Niemueller
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-17 01:55 EDT by Ankur Sinha (FranciscoD)
Modified: 2012-09-17 21:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 19:12:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ankur Sinha (FranciscoD) 2012-09-17 01:55:11 EDT
Description of problem:
Cannot run player

Version-Release number of selected component (if applicable):
player-3.0.2-16.fc17.x86_64


How reproducible:
Always

Steps to Reproduce:
1. cp /usr/share/stage/worlds/simple.cfg ~/dump/player-stage/
2. cd ~/dump/player/stage
3. player simple.cfg
  
Actual results:
[ankur@ankur player-stage]$ player simple.cfg
Registering driver
Player v.3.0.2

* Part of the Player/Stage/Gazebo Project [http://playerstage.sourceforge.net].
* Copyright (C) 2000 - 2009 Brian Gerkey, Richard Vaughan, Andrew Howard,
* Nate Koenig, and contributors. Released under the GNU General Public License.
* Player comes with ABSOLUTELY NO WARRANTY.  This is free software, and you
* are welcome to redistribute it under certain conditions; see COPYING
* for details.

error   : Failed to load plugin stageplugin.
error   : libtool reports error: file not found
error   : plugin search path: /home/ankur/dump/player-stage:.:/usr/lib64/player/:/usr/lib64/
error   : failed to load plugin: stageplugin
error   : failed to parse config file simple.cfg driver blocks

Expected results:
Tutorials describe that the command should give me a GUI window with a simple environment
Comment 1 Rich Mattes 2012-09-17 08:30:21 EDT
Do you have the stage-playerplugin package installed?

Also, you'll need to copy a few more files to your working directory.  simple.cfg relies on simple.world and a couple of .inc files (also found in /usr/share/stage/worlds)
Comment 2 Ankur Sinha (FranciscoD) 2012-09-17 19:12:45 EDT
Hi Rich,

(In reply to comment #1)
> Do you have the stage-playerplugin package installed?

I did not have this installed.

> 
> Also, you'll need to copy a few more files to your working directory. 
> simple.cfg relies on simple.world and a couple of .inc files (also found in
> /usr/share/stage/worlds)

Yeah. I ran it in the /usr/share/stage/worlds directory and it works now. 

I was wondering if it makes sense to pull in the stage-playerplugin package along with stage? For newbies with player/stage (which I am at the moment), it would make it a little simpler. If that isn't possible, should we start populating the wiki with some pages on how to use the fedora robotics packages, the ones that are available?

Thanks again,
Ankur
Comment 3 Rich Mattes 2012-09-17 20:31:21 EDT
(In reply to comment #2)
> I was wondering if it makes sense to pull in the stage-playerplugin package
> along with stage? For newbies with player/stage (which I am at the moment),
> it would make it a little simpler. If that isn't possible, should we start
> populating the wiki with some pages on how to use the fedora robotics
> packages, the ones that are available?
> 

You mean something like this one?
https://fedoraproject.org/wiki/Robotics

I kept them separate because a Stage user won't necessarily use Player, and vice versa.  Though looking at it now, it would make sense to keep all the *.cfg files with the stage-playerplugin package, and only provide *.world and *.inc files with the base Stage package.
Comment 4 Ankur Sinha (FranciscoD) 2012-09-17 21:01:16 EDT
(In reply to comment #3)
> (In reply to comment #2)
> > I was wondering if it makes sense to pull in the stage-playerplugin package
> > along with stage? For newbies with player/stage (which I am at the moment),
> > it would make it a little simpler. If that isn't possible, should we start
> > populating the wiki with some pages on how to use the fedora robotics
> > packages, the ones that are available?
> > 
> 
> You mean something like this one?
> https://fedoraproject.org/wiki/Robotics

Woah! I somehow missed the link on the SIGs/Robotics page. Looks great. :)

> 
> I kept them separate because a Stage user won't necessarily use Player, and
> vice versa.  Though looking at it now, it would make sense to keep all the
> *.cfg files with the stage-playerplugin package, and only provide *.world
> and *.inc files with the base Stage package.

That does seem logical but it isn't a necessary change. Users need both packages installed, and will end up with the required files either way. 

I've created a category for Robotics on the wiki. Will make it a tad bit easier to find all the various pages

https://fedoraproject.org/wiki/Category:Robotics

Thanks,
Ankur

Note You need to log in before you can comment on or make changes to this bug.