Bug 857824 - The response message of do threadump to unsupported app by REST API need update
The response message of do threadump to unsupported app by REST API need update
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Master (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: chris alfonso
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-17 02:53 EDT by Rony Gong
Modified: 2016-01-31 21:35 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 13:50:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rony Gong 2012-09-17 02:53:28 EDT
Description of problem:
Since thread-dump only surpport jboss,  jbossas, ruby now,  then if using REST API do threaddump for unsupported cartridge,  should show useful response like "can't support this kind app", same as  command line interface.
 
 
Version-Release number of selected component (if applicable):
devenv_2182
 
 
How reproducible:
Always
 
 
Steps to Reproduce:
1.Create app for threaddump unsupported cartridge type like(perl, python, nodejs)
2.REST API asccess: curl -k -H 'Accept: application/xml' --user 'qgong@redhat.com:111111' https://ec2-107-20-84-173.compute-1.amazonaws.com/broker/rest/domains/qgong7/applications/qjboss/events -X POST -d event=thread-dump
3.
  
Actual results:
include info:
  <type>application</type>
  <status>ok</status>
  <messages>
    <message>
      <severity>result</severity>
      <field nil="true"></field>
      <text>Added thread-dump to application qperl</text>
      <exit-code>0</exit-code>
    </message>
  </messages>
 
 
Expected results:
should include message like "The threaddump command is not supported by this application type."
  
RESULT:
The threaddump command is not supported by this application type.
  
Additional info:
Comment 1 Rony Gong 2012-09-21 01:51:04 EDT
Also find this error by command line interface, maybe they are one issue, so filed together.

last sprint, for threddump unsupported app, it show message like "The threaddump command is not supported by this application type."

[qgong@localhost dev]$ rhc threaddump qphp
Password: 


RESULT:
Added thread-dump to application qphp
Comment 2 Xiaoli Tian 2012-09-24 22:14:45 EDT
Move it to ON_QA,since https://github.com/openshift/crankcase/pull/521 is merged to master.
Comment 3 Rony Gong 2012-09-25 03:52:23 EDT
verified on devenv_2222
[qgong@localhost dev]$ rhc threaddump qdiy
Password: 


RESULT:
The threaddump command is not supported by this application type.

and REST API
<messages>
    <message>
      <severity>result</severity>
      <field nil="true"></field>
      <exit-code>0</exit-code>
      <text>The threaddump command is not supported by this application type.</text>
    </message>
  </messages>

Note You need to log in before you can comment on or make changes to this bug.