Bug 857890 - Error on running aeolus-cleanup -y
Error on running aeolus-cleanup -y
Status: CLOSED WORKSFORME
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-all (Show other bugs)
1.1.0
x86_64 Linux
unspecified Severity medium
: beta2
: ---
Assigned To: Steve Linabery
Rehana
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-17 08:33 EDT by pushpesh sharma
Modified: 2014-08-04 18:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-18 15:05:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pushpesh sharma 2012-09-17 08:33:33 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Error on running :- aeolus-cleanup -y 
or running : aeolus-cleanup(Then passing "y")


[root@dhcp201-113 ~]# aeolus-cleanup -y
notice: /Stage[main]/Aeolus::Deltacloud::Disabled/Exec[remove_deltacloud_tmp_files]/returns: executed successfully
notice: /Stage[main]/Aeolus::Conductor::Disabled/Aeolus::Rails::Drop::Db[drop_aeolus_database]/Exec[drop_rails_database]/returns: executed successfully
notice: /Stage[main]/Aeolus::Conductor::Disabled/Postgres::User[aeolus]/Exec[drop_aeolus_postgres_user]/returns: could not change directory to "/root"
notice: /Stage[main]/Aeolus::Conductor::Disabled/Postgres::User[aeolus]/Exec[drop_aeolus_postgres_user]/returns: ERROR:  role "aeolus" cannot be dropped because some objects depend on it
notice: /Stage[main]/Aeolus::Conductor::Disabled/Postgres::User[aeolus]/Exec[drop_aeolus_postgres_user]/returns: DETAIL:  owner of database conductor
notice: /Stage[main]/Aeolus::Conductor::Disabled/Postgres::User[aeolus]/Exec[drop_aeolus_postgres_user]/returns: 94 objects in database conductor
err: /Stage[main]/Aeolus::Conductor::Disabled/Postgres::User[aeolus]/Exec[drop_aeolus_postgres_user]/returns: change from notrun to 0 failed: su postgres -c "psql postgres postgres -c                          \"DROP USER aeolus\"" returned 1 instead of one of [0] at /usr/share/aeolus-configure/modules/postgres/manifests/user.pp:12
notice: /Stage[main]/Aeolus::Image-factory::Disabled/Exec[remove_imagefactory_tmp_files]/returns: executed successfully
notice: /Stage[main]/Aeolus::Image-factory::Disabled/Exec[remove_aeolus_templates]/returns: executed successfully
notice: Finished catalog run in 7.33 seconds











[root@dhcp201-113 ~]# rpm -qa|grep aeolus
aeolus-conductor-0.13.7-1.el6cf.noarch
aeolus-all-0.13.7-1.el6cf.noarch
aeolus-conductor-daemons-0.13.7-1.el6cf.noarch
aeolus-configure-2.8.6-1.el6cf.noarch
aeolus-conductor-doc-0.13.7-1.el6cf.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
Comment 2 Steve Linabery 2012-09-18 10:58:07 EDT
yeah, I can repro this. looking into it.
Comment 3 Dave Johnson 2012-09-18 15:05:09 EDT
Unable to reproduce using the latest rpms from today's puddle

aeolus-all-0.13.8-1.el6cf.noarch
aeolus-conductor-0.13.8-1.el6cf.noarch
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch
aeolus-configure-2.8.6-1.el6cf.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
Comment 4 Steve Linabery 2012-09-18 15:42:52 EDT
I retract my statement about being able to reproduce this.

The first time I tried, I had some stale delayed-job processes that were holding connections to postgresql. So (and please make a note of this!) 'rake db:drop' was failing, but still exiting with 0.

Once I cleaned up the processes, I ran it again and cleanup was failing for a different reason, this time because I am using a non-fresh RHEL installation, and someone had set up test/devel dbs. So I manually dropped those.

Since then I have (via a script) cycled configure/cleanup 50 times without any errors. So, I'm saying at this point that I cannot reproduce it.

Slightly different package list from latest puddle:
[root@virtlab31 ~]# rpm -qa | grep aeolus
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-conductor-0.13.8-1.el6cf.noarch
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
aeolus-all-0.13.8-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch
rubygem-ZenTest-4.3.3-2.aeolus.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-arel-2.0.10-0.aeolus.el6.noarch
aeolus-configure-2.8.6-1.el6cf.noarch

I'm going to try this on a fresh RHEL vm, but I should point out that eck has also told me he can't break it.

Note You need to log in before you can comment on or make changes to this bug.