Bug 857937 - exit with error if old spice-server is used and '-spice seamless-migration=on' option
exit with error if old spice-server is used and '-spice seamless-migration=on...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity medium
: beta
: ---
Assigned To: Gerd Hoffmann
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-17 10:30 EDT by David Jaša
Modified: 2013-02-21 02:39 EST (History)
12 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.320.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 02:39:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2012-09-17 10:30:50 EDT
Description of problem:
exit with error if old spice-server is used and '-spice seamless-migration=on' option

Version-Release number of selected component (if applicable):
qemu-kvm-0.12.1.2-2.312.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. use 6.4 qemu-kvm with 6.3 spice-server
2. run qemu with option above
3.
  
Actual results:
qemu-kvm happily runs

Expected results:
qemu-kvm exits with error that the option is invalid with current version of spice-server

Additional info:
Comment 1 mazhang 2012-09-25 01:12:58 EDT
(In reply to comment #0)
> Description of problem:
> exit with error if old spice-server is used and '-spice
> seamless-migration=on' option
> 
> Version-Release number of selected component (if applicable):
> qemu-kvm-0.12.1.2-2.312.el6.x86_64


Try to reproduce this bug by qemu-kvm&&spice-server&&kernel:
qemu-kvm-0.12.1.2-2.312.el6.x86_64
spice-server-0.10.1-2.el6.x86_64
2.6.32-303.el6.x86_64

qemu-kvm runs well, can't got the error.
Could please tell me your spice-sever version or detail record of this issue.
Comment 5 David Jaša 2012-09-25 05:04:55 EDT
(In reply to comment #1)
> (In reply to comment #0)
> > Description of problem:
> > exit with error if old spice-server is used and '-spice
> > seamless-migration=on' option
> > 
> > Version-Release number of selected component (if applicable):
> > qemu-kvm-0.12.1.2-2.312.el6.x86_64
> 
> 
> Try to reproduce this bug by qemu-kvm&&spice-server&&kernel:
> qemu-kvm-0.12.1.2-2.312.el6.x86_64
> spice-server-0.10.1-2.el6.x86_64
> 2.6.32-303.el6.x86_64
> 
> qemu-kvm runs well, can't got the error.
> Could please tell me your spice-sever version or detail record of this issue.

I meant it the other way around, exactly as Gerd understood. The problem is that seamless-migration=on requires newer spice-server so if older spice-server is used, qemu _should_ exit with error instead of quiet proceeding.
Comment 12 Qunfang Zhang 2012-10-09 01:28:36 EDT
I can not reproduce as well but checked the build log of qemu-kvm-0.12.1.2-2.320.el6 in brewweb, it does require spice-server 0.12+ to build qemu-kvm for 6.4.

In unfixed qemu-kvm-0.12.1.2-2.318.el6:
In the build log:
'spice-server-devel >= 0.10.1-2.el6' 
DEBUG util.py:256:  0:spice-server-devel-0.10.1-10.el6.x86_64

In qemu-kvm-0.12.1.2-2.320.el6:
'spice-server-devel >= 0.12.0'
DEBUG util.py:256:    spice-server-devel.x86_64 0:0.12.0-1.el6          

So, I will set this bug to verified. Please correct me if I am wrong.
Comment 13 errata-xmlrpc 2013-02-21 02:39:53 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0527.html

Note You need to log in before you can comment on or make changes to this bug.