This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 857976 - [abrt] ibus-m17n-1.3.4-4.fc18: on_context_destroyed: Process /usr/libexec/ibus-engine-m17n was killed by signal 11 (SIGSEGV)
[abrt] ibus-m17n-1.3.4-4.fc18: on_context_destroyed: Process /usr/libexec/ibu...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ibus-m17n (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daiki Ueno
Fedora Extras Quality Assurance
abrt_hash:7d85b085df262ffadcccf6ab3d1...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-17 12:28 EDT by Abhay
Modified: 2012-09-21 01:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-21 01:21:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: core_backtrace (1.70 KB, text/plain)
2012-09-17 12:28 EDT, Abhay
no flags Details
File: environ (1005 bytes, text/plain)
2012-09-17 12:28 EDT, Abhay
no flags Details
File: backtrace (16.67 KB, text/plain)
2012-09-17 12:28 EDT, Abhay
no flags Details
File: limits (1.29 KB, text/plain)
2012-09-17 12:28 EDT, Abhay
no flags Details
File: cgroup (128 bytes, text/plain)
2012-09-17 12:28 EDT, Abhay
no flags Details
File: maps (30.25 KB, text/plain)
2012-09-17 12:28 EDT, Abhay
no flags Details
File: dso_list (6.29 KB, text/plain)
2012-09-17 12:28 EDT, Abhay
no flags Details
File: var_log_messages (166 bytes, text/plain)
2012-09-17 12:28 EDT, Abhay
no flags Details
File: open_fds (412 bytes, text/plain)
2012-09-17 12:28 EDT, Abhay
no flags Details
Screenshot that shows "Screen Keyboard" menu is not available on GNOME3 (30.71 KB, image/png)
2012-09-21 00:30 EDT, Daiki Ueno
no flags Details
screenshot that shows how i inoveked the eekboard (939.56 KB, image/png)
2012-09-21 01:04 EDT, Abhay
no flags Details

  None (edit)
Description Abhay 2012-09-17 12:28:31 EDT
Version-Release number of selected component:
ibus-m17n-1.3.4-4.fc18

Additional info:
libreport version: 2.0.13
abrt_version:   2.0.12
backtrace_rating: 3
cmdline:        /usr/libexec/ibus-engine-m17n --ibus
crash_function: on_context_destroyed
kernel:         3.3.4-5.fc17.x86_64

truncated backtrace:
:Thread no. 1 (8 frames)
: #0 on_context_destroyed at eekboard-client.c
: #5 do_call at gdbusnamewatching.c
: #6 call_vanished_handler at gdbusnamewatching.c
: #8 on_name_owner_changed at gdbusnamewatching.c
: #10 emit_signal_instance_in_idle_cb at gdbusconnection.c
: #15 ibus_write_address at /lib64/libibus-1.0.so.5
: #16 ??
: #17 ??
Comment 1 Abhay 2012-09-17 12:28:34 EDT
Created attachment 613719 [details]
File: core_backtrace
Comment 2 Abhay 2012-09-17 12:28:36 EDT
Created attachment 613721 [details]
File: environ
Comment 3 Abhay 2012-09-17 12:28:40 EDT
Created attachment 613723 [details]
File: backtrace
Comment 4 Abhay 2012-09-17 12:28:42 EDT
Created attachment 613725 [details]
File: limits
Comment 5 Abhay 2012-09-17 12:28:45 EDT
Created attachment 613727 [details]
File: cgroup
Comment 6 Abhay 2012-09-17 12:28:48 EDT
Created attachment 613729 [details]
File: maps
Comment 7 Abhay 2012-09-17 12:28:51 EDT
Created attachment 613731 [details]
File: dso_list
Comment 8 Abhay 2012-09-17 12:28:54 EDT
Created attachment 613733 [details]
File: var_log_messages
Comment 9 Abhay 2012-09-17 12:28:57 EDT
Created attachment 613735 [details]
File: open_fds
Comment 10 Daiki Ueno 2012-09-18 02:03:48 EDT
Could you please provide a reproducible steps?  I can't repeat it here.
Comment 11 Abhay 2012-09-18 05:26:14 EDT
I was executing the test case listed here:
https://fedoraproject.org/wiki/QA:Eekboard

Following are the steps i followed:

1. Opened eekeyboard
2. clicked "Setup" button on the bottom right corner
3. selected "Keyboards" tab
4. clicked "Add" button and selected "Marathi (inscript)"

When i went to the "setup" window, some button on the eekeyboard kept focused. And the problem with the eekeyboard is even if you don't press the key and it's kept focused, the eekeyboard simulates the keypress event. So i guess indefinitely generating the keypress events caused this bug.

Two bugs have been occured because of this scenario:

1. Bug #857976 in ibus-m17n
2. Bug #857977 in eekeyboard
Comment 12 Daiki Ueno 2012-09-18 22:28:04 EDT
(In reply to comment #11)
> I was executing the test case listed here:
> https://fedoraproject.org/wiki/QA:Eekboard
> 
> Following are the steps i followed:
> 
> 1. Opened eekeyboard
> 2. clicked "Setup" button on the bottom right corner
> 3. selected "Keyboards" tab
> 4. clicked "Add" button and selected "Marathi (inscript)"

I still can't reproduce it with recent i18n test live image:
http://dl.fedoraproject.org/pub/alt/qa/18/20120818_i18n-testday/

And this bug is a crash in ibus-m17n not eekboard itself, so I don't think the above steps reproduce the same result.

Could you provide more precise information?

> When i went to the "setup" window, some button on the eekeyboard kept
> focused. And the problem with the eekeyboard is even if you don't press the
> key and it's kept focused, the eekeyboard simulates the keypress event. So i
> guess indefinitely generating the keypress events caused this bug.

Sorry, I don't understand what you mean here.  Do you mean you tried to type something on the setup dialog with eekboard?
Comment 13 Abhay 2012-09-19 00:34:44 EDT
(In reply to comment #12)
> (In reply to comment #11)
> > I was executing the test case listed here:
> > https://fedoraproject.org/wiki/QA:Eekboard
> > 
> > Following are the steps i followed:
> > 
> > 1. Opened eekeyboard
> > 2. clicked "Setup" button on the bottom right corner
> > 3. selected "Keyboards" tab
> > 4. clicked "Add" button and selected "Marathi (inscript)"
> 
> I still can't reproduce it with recent i18n test live image:
> http://dl.fedoraproject.org/pub/alt/qa/18/20120818_i18n-testday/
> 
> And this bug is a crash in ibus-m17n not eekboard itself, so I don't think
> the above steps reproduce the same result.

The first fous steps were the prologue of what i did, they didn't produce the crash.

> Could you provide more precise information?
> 
> > When i went to the "setup" window, some button on the eekeyboard kept
> > focused. And the problem with the eekeyboard is even if you don't press the
> > key and it's kept focused, the eekeyboard simulates the keypress event. So i
> > guess indefinitely generating the keypress events caused this bug.
> 
> Sorry, I don't understand what you mean here.  Do you mean you tried to type
> something on the setup dialog with eekboard?


I was selecting the keyboard input layout in the setup dialogue. And the input langauge source at that time was itrans(m17n). When i went from eekeyboard to the setup dialogue box, one of the keys on eekeyboard left focused(that is it turned blue from it's default black color). And the problem with eekeyboard is even if you are not pressing keys on eekeyboard, but if the key has got focus, the eekeyboard generates keypress events for that key.
Comment 14 Daiki Ueno 2012-09-19 01:42:04 EDT
(In reply to comment #13)
> The first fous steps were the prologue of what i did, they didn't
> produce the crash.

I'm asking for "the steps to reproduce the crash".  Otherwise I can't
investigate the cause of the crash.  You might want to look at:
http://www.chiark.greenend.org.uk/~sgtatham/bugs.html for better bug
report.

> And the problem with eekeyboard is even if you are not pressing keys
> on eekeyboard, but if the key has got focus, the eekeyboard
> generates keypress events for that key.

I don't think this has to do with the crash bug we are talking on.
Please file a separate bug instead.  Also, the component name is
eekboard, not "eekeyboard".
Comment 15 Abhay 2012-09-19 05:52:00 EDT
Steps to regenerate the bug:

1. Change input language to itrans(m17n)
2. Open Eekboard 
3. Click on the Setup button on the Eekboard
4. Hover the mouse pointer(or cursor) on ESC button of the Eekboard
Comment 16 Daiki Ueno 2012-09-19 21:13:18 EDT
(In reply to comment #15)
> Steps to regenerate the bug:
> 
> 1. Change input language to itrans(m17n)
> 2. Open Eekboard 
> 3. Click on the Setup button on the Eekboard
> 4. Hover the mouse pointer(or cursor) on ESC button of the Eekboard

Still can't reproduce it.  What I did is:

1. get the i18n test day live image:
http://dl.fedoraproject.org/pub/alt/qa/18/20120818_i18n-testday/
2. run it with kvm:
qemu-kvm -vga std -net nic -net user -m 2G -boot d -cdrom 20120917-fedora-18-i18n-testday-live.x86_64.iso
3. select "Live System User" -> "System Settings" -> "Details" -> "Graphics" -> "Forced Fallback Mode" on
4. run gnome-terminal and type "gnome-session-quit" to logout
5. re-login
6. enable ibus with im-chooser
7. run ibus-setup and add "Marathi - itrans (m17n)" to input methods
8. switch to "Marathi - itrans (m17n)"
9. click on the IBus status icon and select "Screen Keyboard" (then eekboard is shown)
10. Click on the Setup button on eekboard (nothing happens)
11. Hover the mouse pointer on Esc button of eekboard

What's the difference between your recipe and mine?  Can you try the above steps?
Comment 17 Abhay 2012-09-20 00:04:19 EDT
This error occured on my phyisical machine and not on virtual machine.

1.When i try to open im-chooser from the gnome-terminal, the window opens with the following warning in the gnome-terminal:

(im-chooser:2458): libimchooseui-WARNING **: GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._imsettings_2derror_2dquark.Code5: Current desktop isn't targeted by Input Method.

2.When i click on "Use Ibus (recommended)", the message box comes out saying "Failed to switch input method" and the following description:

GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._imsettings_2derror_2dquark.Code5: Current desktop isn't targeted by Input Method.

3. I chose the input source using Region & Language Settings.
Comment 18 Daiki Ueno 2012-09-20 04:09:19 EDT
(In reply to comment #17)
> This error occured on my phyisical machine and not on virtual machine.
> 
> 1.When i try to open im-chooser from the gnome-terminal, the window opens
> with the following warning in the gnome-terminal:
> 
> (im-chooser:2458): libimchooseui-WARNING **:
> GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._imsettings_2derror_2dquark.
> Code5: Current desktop isn't targeted by Input Method.
> 
> 2.When i click on "Use Ibus (recommended)", the message box comes out saying
> "Failed to switch input method" and the following description:
> 
> GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._imsettings_2derror_2dquark.
> Code5: Current desktop isn't targeted by Input Method.
> 
> 3. I chose the input source using Region & Language Settings.

Yes, that is expected.  As I wrote in comment 16, I asked to try it on "Fallback mode" instead normal GNOME session, since there is no way to activate eekboard from ibus-m17n on normal GNOME session.

Anyway, I'm now more confused - what's your desktop environment and how did you activate eekboard from ibus-m17n?
Comment 19 Abhay 2012-09-20 08:13:48 EDT
(In reply to comment #18)
> (In reply to comment #17)
> > This error occured on my phyisical machine and not on virtual machine.
> > 
> > 1.When i try to open im-chooser from the gnome-terminal, the window opens
> > with the following warning in the gnome-terminal:
> > 
> > (im-chooser:2458): libimchooseui-WARNING **:
> > GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._imsettings_2derror_2dquark.
> > Code5: Current desktop isn't targeted by Input Method.
> > 
> > 2.When i click on "Use Ibus (recommended)", the message box comes out saying
> > "Failed to switch input method" and the following description:
> > 
> > GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._imsettings_2derror_2dquark.
> > Code5: Current desktop isn't targeted by Input Method.
> > 
> > 3. I chose the input source using Region & Language Settings.
> 
> Yes, that is expected.  As I wrote in comment 16, I asked to try it on
> "Fallback mode" instead normal GNOME session, since there is no way to
> activate eekboard from ibus-m17n on normal GNOME session.
> 

1. I made "Forced Fallback Mode" on and re-logged in to the system

2. When i ran ibus-setup, it opens  with the fallowing warnings:
(main.py:4422): IBUS-WARNING **: org.freedesktop.IBus.Config.GetValue: GDBus.Error:org.freedesktop.DBus.Error.Failed: Config value [general:load_xkb_layouts] does not exist.

(main.py:4422): IBUS-WARNING **: org.freedesktop.IBus.Config.GetValue: GDBus.Error:org.freedesktop.DBus.Error.Failed: Config value [general/xkblayoutconfig:group_list] does not exist.

but i am able to add "Marathi - itrans (m17n)" to the input methods.

3. Then i clicked on the ibus status icon and selected the Marathi -itrans(m17n). As soon as i did this, the icon turns invisible, but i am able to type in Marathi(with my real keypad).

4. When i try to type with screen keyboard(Eekboard) in Marathi, it still echoes the English characters.

5. Clicked on the setup key on the eekboard, nothing happened.

6. hovered the cursor on ESC key, the eekboard simulated the ESC keypress events.


> Anyway, I'm now more confused - what's your desktop environment and how did
> you activate eekboard from ibus-m17n?

My desktop environment is Gnome 3.5.91. I did nothing special to activate eekboard for ibus-m17n. i added the Marathi-itrans(m17n) input method from  System Settings -> Region & Language -> Input Sources.
Comment 20 Daiki Ueno 2012-09-21 00:30:01 EDT
Created attachment 615278 [details]
Screenshot that shows "Screen Keyboard" menu is not available on GNOME3

(In reply to comment #19)

> 1. I made "Forced Fallback Mode" on and re-logged in to the system
...
> 5. Clicked on the setup key on the eekboard, nothing happened.
> 
> 6. hovered the cursor on ESC key, the eekboard simulated the ESC keypress
> events.

So, you mean, you didn't get the crash this time?

> > Anyway, I'm now more confused - what's your desktop environment and how did
> > you activate eekboard from ibus-m17n?
> 
> My desktop environment is Gnome 3.5.91. I did nothing special to activate
> eekboard for ibus-m17n. i added the Marathi-itrans(m17n) input method from 
> System Settings -> Region & Language -> Input Sources.

In that case, you shouldn't see "Screen Keyboard" menu item, since it is hidden under normal GNOME session (see the screenshot).  If you are able to launch eekboard from ibus-m17n on GNOME 3, you are doing something special.  Please be more precise and provide useful information (like "how did you installed the system", etc).

Otherwise I would like to close this (and bug 857977 and bug 858186) as worksforme.
Comment 21 Abhay 2012-09-21 01:03:10 EDT
(In reply to comment #20)
> Created attachment 615278 [details]
> Screenshot that shows "Screen Keyboard" menu is not available on GNOME3
> 
> (In reply to comment #19)
> 
> > 1. I made "Forced Fallback Mode" on and re-logged in to the system
> ...
> > 5. Clicked on the setup key on the eekboard, nothing happened.
> > 
> > 6. hovered the cursor on ESC key, the eekboard simulated the ESC keypress
> > events.
> 
> So, you mean, you didn't get the crash this time?
> 

no, i did not get crash this time.

> > > Anyway, I'm now more confused - what's your desktop environment and how did
> > > you activate eekboard from ibus-m17n?
> > 
> > My desktop environment is Gnome 3.5.91. I did nothing special to activate
> > eekboard for ibus-m17n. i added the Marathi-itrans(m17n) input method from 
> > System Settings -> Region & Language -> Input Sources.
> 
> In that case, you shouldn't see "Screen Keyboard" menu item, since it is
> hidden under normal GNOME session (see the screenshot).  If you are able to
> launch eekboard from ibus-m17n on GNOME 3, you are doing something special. 
> Please be more precise and provide useful information (like "how did you
> installed the system", etc).
> 
> Otherwise I would like to close this (and bug 857977 and bug 858186) as
> worksforme.

No, i don't see "Screen Keyboard" menu item on ibus (input language) icon on the panel. I invoke the eekboard from choosing it from Accessories Menu (please see the screenshot).

I installed Fedora 17 from Live CD, and then followed the steps given on 

http://fedoraproject.org/wiki/Upgrading_Fedora_using_yum#Fedora_17_-.3E_Fedora_18 to upgrade it to Fedora 18
Comment 22 Abhay 2012-09-21 01:04:20 EDT
Created attachment 615280 [details]
screenshot that shows how i inoveked the eekboard
Comment 23 Daiki Ueno 2012-09-21 01:21:52 EDT
(In reply to comment #21)

> > So, you mean, you didn't get the crash this time?
> > 
> 
> no, i did not get crash this time.

OK.

> No, i don't see "Screen Keyboard" menu item on ibus (input language) icon on
> the panel. I invoke the eekboard from choosing it from Accessories Menu
> (please see the screenshot).

The information is not helpful, as this bug is crash in ibus-m17n (not in eekboard) as the title says:

[abrt] ibus-m17n-1.3.4-4.fc18: on_context_destroyed: Process /usr/libexec/ibus-engine-m17n was killed by signal 11 (SIGSEGV)

> I installed Fedora 17 from Live CD, and then followed the steps given on 
> 
> http://fedoraproject.org/wiki/Upgrading_Fedora_using_yum#Fedora_17_-.
> 3E_Fedora_18 to upgrade it to Fedora 18

As the wiki page says it is unsupported way and you cannot reproduce the problem with the recent live media, the problem is most likely in your system setup.

Closing as worksforme - if you encounter the same problem with fresh install, please reopen.

Note You need to log in before you can comment on or make changes to this bug.