Bug 85801 - Dell PowerEdge 4600 shows hardware problem when Linux starts
Dell PowerEdge 4600 shows hardware problem when Linux starts
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Larry Woodman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-07 16:38 EST by Boris Mironov
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-18 08:33:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Boris Mironov 2003-03-07 16:38:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 4.0)

Description of problem:
Hello,

We use Dell PowerEdge 4600. Sometimes during the start of Linux Redhat AS 2.1 
hardware monitor shows errors:
E13F4 PCI PARITY
E13F5 PCI SYSTEM

I have been advised by Dell technical support that cause of the problem is AIC-
7xxx. In order to fix it you have to install fix that available at: 

http://people.freebsd.org/~gibbs/linux/

Unfortunately, I was not able to install it under kernel 2.4.9-e.12smp because 
of image abscence.

Could you please incorparete it in the kernel?

Thanks a lot,
Boris

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. It is intermitten problem that occurs usually on boot time of Linux
2.
3.
    

Additional info:
Comment 1 Boris Mironov 2003-03-11 12:15:57 EST
Hi Larry,

Just a little note.
When Linux initializes drivers for SCSI messages (E13F4, E13F5) appear on 
hardware monitor. At same time /var/log/messages shows:

kernel: SCSI subsystem driver. Revision: 1.00
kernel: Uhhuh. NMI received. Dazed and confused, but trying to continue
kernel: Uhhuh. NMI received. Dazed and confused, but trying to continue
kernel: You probably have a hardware problem with your RAM chips
kernel: Uhhuh. NMI received. Dazed and confused, but trying to continue
kernel: You probably have a hardware problem with your RAM chips
kernel: You probably have a hardware problem with your RAM chips
kernel: (scsi0) <Adaptec AIC-7890/1 Ultra2 SCSI host adapter> found at PCI 
0/6/0
kernel: (scsi0) Wide Channel, SCSI ID=7, 32/255 SCBs
kernel: (scsi0) Downloading sequencer code... 398 instructions downloaded
kernel: scsi0 : Adaptec AHA274x/284x/294x (EISA/VLB/PCI-Fast SCSI) 5.2.5/5.2.0
kernel:        <Adaptec AIC-7890/1 Ultra 2 SCSI host adapter>
kernel: blk:  queue c4f30e18, I/O limit 4095Mb (mask 0xffffffff)

Nothing has connected to this adapter :o(
When this problem arise the rest of SCSI adapters work much slower.
The only solution is just total power shutdown for the computer, crossing 
fingers, knocking the wood and hoping to sneak around the problem. ;o)

Hope it will help.

Thanks,
Boris
Comment 2 Boris Mironov 2003-06-13 16:00:04 EDT
Hi guys,

Today I restarted the system under latest available kernel (2.4.9-e.24smp) and 
problem appeared again :o(

Best regards,
Boris
Comment 3 Boris Mironov 2003-08-19 11:22:00 EDT
Hello,

It still exists under kernel 2.4.9-e25smp :o(

Regards,
Boris
Comment 4 John A. Hull 2004-05-25 08:19:06 EDT
Kernel 2.4.9-e.34 or later should have the fix. 
Comment 5 Matt Domsch 2004-08-18 08:33:52 EDT
Fixed in 2.4.9-e.34 and newer.  Closing.

Note You need to log in before you can comment on or make changes to this bug.