Bug 858110 - change the device in the man page of thin_check, thin_dump & thin_restore
change the device in the man page of thin_check, thin_dump & thin_restore
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: device-mapper-persistent-data (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Peter Rajnoha
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-17 22:02 EDT by Xiaowei Li
Modified: 2015-01-26 19:10 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-14 03:44:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xiaowei Li 2012-09-17 22:02:37 EDT
Description of problem:
thin_check manpage issue:
there is an example in thin_check.
====
     thin_check /dev/vg/metadata
====

it's better to change the device to /dev/mapper/vg-pool_tmeta since the internal thin meta device is not accessed in /dev/vg/.

same issues for thin_dump & thin_restore.


Version-Release number of selected component (if applicable):
device-mapper-persistent-data-0.1.4-2.el7.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 3 Zdenek Kabelac 2012-12-14 03:44:01 EST
It's only as an example.

Current version of (2.02.98-5) lvm2 allows you to i.e. 'export/swap' metadata from thin pool to a normal LV - and you could use then  thin_check on a normal LV - fix metadata/ backup&restore them to bigger partition.

So I think the man page could be left as it is.

User should never try to fix/run  think_check on 'running'  thin pool.
The only exception currently is, when thin pool fails to start -
we leave the thin metadata device active - but it's rather 'temporary'
solution - and at this moment we should probably already disable this use,
since there is a way, to fix thin pool without this.

Obviously we are missing proper documentation how to fix thin pool metadata
with current lvm2 utilities, which needs to be written.
Comment 4 Steven J. Levine 2014-07-09 18:14:59 EDT
BZ#1022850 is a separate BZ for documenting fixing thin pool metadata with current lvm2 utilities.

There is now an lvmthin(7) man page which may address this issue.

Note You need to log in before you can comment on or make changes to this bug.