Bug 858172 - amanda rpm should not provide the perl(Math::BigInt) capability
amanda rpm should not provide the perl(Math::BigInt) capability
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: amanda (Show other bugs)
7.0
Unspecified Linux
low Severity high
: rc
: ---
Assigned To: Petr Pisar
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-18 05:09 EDT by Petr Pisar
Modified: 2012-09-19 01:54 EDT (History)
1 user (show)

See Also:
Fixed In Version: amanda-3.3.2-2.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 648321
Environment:
Last Closed: 2012-09-19 01:54:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2012-09-18 05:09:17 EDT
+++ This bug was initially created as a clone of Bug #648321 +++

Description of problem: The amanda rpm should not provide the perl(Math::BigInt) capability.  


Version-Release number of selected component (if applicable): 0:2.6.1p2-4.fc13


How reproducible: Use repoquery to see the problem.


Steps to Reproduce:
1. repoquery --whatprovides 'perl(Math::BigInt)'
2.
3.
  
Actual results:
-bash-4.1# repoquery --whatprovides 'perl(Math::BigInt)'
perl-4:5.10.1-120.fc13.x86_64
amanda-0:2.6.1p2-4.fc13.i686
amanda-0:2.6.1p2-3.fc13.x86_64
perl-4:5.10.1-112.fc13.i686
perl-4:5.10.1-112.fc13.x86_64
amanda-0:2.6.1p2-3.fc13.i686
amanda-0:2.6.1p2-4.fc13.x86_64



Expected results: Should be provided by the perl rpm and not by amanda.


Additional info:

--- Additional comment from jgorig@redhat.com on 2010-11-04 17:36:17 GMT ---

Thank you for your bug report. I have fixed this bug in amanda-3.2.0-1.fc15. If you want to have this bug fixed in earlier version of Fedora, please reopen this bug. Closing Rawhide.

--- Additional comment from paul@city-fan.org on 2012-03-27 14:34:20 GMT ---

RPM provides/excludes mechanisms changed in rpm 4.9, introduced in Fedora 15, with the result that in Fedora 15 onwards, this bug has re-appeared.

Adding the following line alongside the existing filter should fix this without breaking compatibility with older distributions:

%global __provides_exclude ^perl\\(Math::BigInt\\)

--- Additional comment from paul@city-fan.org on 2012-08-08 07:24:41 GMT ---

Still broken in F-17.

--- Additional comment from ppisar@redhat.com on 2012-09-18 09:03:56 GMT ---

F19, F18 broken too.
-------

RHEL-7 is affected too.

Note You need to log in before you can comment on or make changes to this bug.