Bug 858203 - Should have meaningful error message when adding cartridge for a scalable app while dns is outage
Should have meaningful error message when adding cartridge for a scalable app...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Ravi Sankar
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-18 06:12 EDT by Wei Sun
Modified: 2015-05-14 22:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 13:48:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wei Sun 2012-09-18 06:12:58 EDT
Description of problem:

Try to add cartridge for a scalable app when dns is outage, user will get non-meaning full error like :exception object expected

Should give  meaningful error message like :Error communicating with DNS system.

Version-Release number of selected component (if applicable):

devenv_2188
devenv-stage_239

How reproducible:
always

Steps to Reproduce:
1.Add cartrdige to a scalable app when dns is outage
2.
3.
  
Actual results:

[sunwei@dhcp-8-229 stage]$ rhc app cartridge add -a r9s -c mysql-5.1 -l jinzhang+6@redhat.com -p redhat -d 
Contacting https://stg.openshift.redhat.com
Problem reported from server. Response code was 500.
DEBUG:
exception object expected/usr/lib/ruby/gems/1.8/gems/stickshift-controller-0.16.5/lib/stickshift-controller/app/models/application.rb:493:in `raise'
/usr/lib/ruby/gems/1.8/gems/stickshift-controller-0.16.5/lib/stickshift-controller/app/models/application.rb:493:in `configure_dependencies'
/usr/lib/ruby/gems/1.8/gems/stickshift-controller-0.16.5/lib/stickshift-controller/app/models/application.rb:1067:in `add_dependency'
/usr/lib/ruby/gems/1.8/gems/stickshift-controller-0.16.5/lib/stickshift-controller/app/controllers/legacy_broker_controller.rb:335:in `embed_cartridge_post'
/usr/lib/ruby/gems/1.8/gems/actionpack-3.0.13/lib/action_controller/metal/implicit_render.rb:4:in `send_action'
/usr/lib/ruby/gems/1.8/gems/actionpack-3.0.13/lib/action_controller/metal/implicit_render.rb:4:in `send_action'
Exit Code: 1
broker_c: ["namespace", "rhlogin", "ssh", "app_uuid", "debug", "alter", "cartridge", "cart_type", "action", "app_name", "api"]
api_c: ["placeholder"]
API version:    1.1.3
RESULT:
exception object expected

Expected results:
Give meaningful error message:Error communicating with DNS system.

Additional info:
Comment 1 Xiaoli Tian 2012-10-12 00:25:31 EDT
Move it to ON_QA, since this pull request is merged:
https://github.com/openshift/origin-server/pull/654
Comment 2 Wei Sun 2012-10-12 06:58:45 EDT
 verified on devenv_2320,
 client rhc-0.99.5.gem(build from fork_226)

 Step:
 1.Add cartrdige to a scalable app when dns is outage
  rhc cartridge add 

 Result:
 [sunwei@dhcp-8-229 ~]$ rhc cartridge add mysql-5.1  -a phpscaletest -p redhat
Adding 'mysql-5.1' to application 'phpscaletest'
Error communicating with DNS system.  If the problem persists please contact Red Hat support.

Note You need to log in before you can comment on or make changes to this bug.