Bug 858237 - nova-scheduler needs a restart in order to be able to boot an instance
nova-scheduler needs a restart in order to be able to boot an instance
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openstack-nova (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-18 08:12 EDT by Nikola Dipanov
Modified: 2016-04-22 01:01 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-09 07:55:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nikola Dipanov 2012-09-18 08:12:13 EDT
Description of problem:

After following steps for Fedora test day on https://fedoraproject.org/wiki/Test_Day:2012-09-18_OpenStack nova boot was failing with:

2012-09-18 12:54:59 WARNING nova.scheduler.manager [req-97f0d033-6a3e-4e89-8cc1-38d
2a5235d55 c695bad39d17436eb96c5f748ed2dd47 b670bf3efaee479194f284861a363b5d] Failed
 to schedule_run_instance: No valid host was found. 
2012-09-18 12:54:59 WARNING nova.scheduler.manager [req-97f0d033-6a3e-4e89-8cc1-38d
2a5235d55 c695bad39d17436eb96c5f748ed2dd47 b670bf3efaee479194f284861a363b5d] [insta
nce: 6fbac148-9fd2-469d-8c18-e0de4646faf7] Setting instance to ERROR state.

Restarting the scheduler solved the problem.

Version-Release number of selected component (if applicable):

F-17

How reproducible:


Steps to Reproduce:

Follow steps on https://fedoraproject.org/wiki/Test_Day:2012-09-18_OpenStack until the 'launch an instance' step.
  
Actual results:


Expected results:


Additional info:
Comment 1 Mark McLoughlin 2012-09-18 08:13:33 EDT
Set version to 18 because this is the f18 version of openstack
Comment 2 Mark McLoughlin 2012-09-18 08:14:27 EDT
Hmm, we need to get to the bottom of what's causing the scheduler to not consider the host valid ... and why that changes after a restart
Comment 3 Nikola Dipanov 2012-09-18 13:28:23 EDT
After some more poking around - this seems to have beed a RAM issue in my VM (although needs to be confirmed).

However logging should be more helpfull than this.
Comment 4 Mark McLoughlin 2012-09-24 05:59:09 EDT
Ok, sounds like we need more details to figure out exactly what was going on here.

If the only improvement we need to make is just to improve logging, that can be a bug we file directly upstream
Comment 5 Nikola Dipanov 2012-09-24 11:17:52 EDT
I will try to reproduce and update the bug accordingly.
Comment 6 Nikola Dipanov 2012-10-09 07:07:26 EDT
(In reply to comment #4)
> Ok, sounds like we need more details to figure out exactly what was going on
> here.
> 

I tried to reproduce this - but cannot get this behavior with the latest packages (2012.2-1.fc18). The scheduler acts as expected and reports that there isn't enugh memory when trying to start a large enough instance to warrant it.

> If the only improvement we need to make is just to improve logging, that can
> be a bug we file directly upstream

Loging can be made more helpful with debug mode turned on, so we don't really need to report a bug upstream.

Note You need to log in before you can comment on or make changes to this bug.