Bug 858242 - io-cache is masking readv error
io-cache is masking readv error
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: io-cache (Show other bugs)
mainline
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Raghavendra G
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-18 08:19 EDT by Pranith Kumar K
Modified: 2014-04-17 07:39 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-17 07:39:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2012-09-18 08:19:58 EDT
Description of problem:

#0  fuse_readv_cbk (frame=0x7fd9a85ad79c, cookie=0x7fd9a87b702c, this=0x17f0b30, op_ret=0, op_errno=116, vector=0x180a640, count=0, stbuf=0x7fffbfe8b960, iobref=0x180a4e0, xdata=0x0)
    at fuse-bridge.c:2019
#1  0x00007fd9a4a27ebd in io_stats_readv_cbk (frame=0x7fd9a87b702c, cookie=0x7fd9a87b7388, this=0x18174b0, op_ret=0, op_errno=116, vector=0x180a640, count=0, buf=0x7fffbfe8b960, 
    iobref=0x180a4e0, xdata=0x0) at io-stats.c:1342
#2  0x00007fd9a4c41b74 in mdc_readv_cbk (frame=0x7fd9a87b7388, cookie=0x7fd9a87b7184, this=0x18163d0, op_ret=0, op_errno=116, vector=0x180a640, count=0, stbuf=0x7fffbfe8b960, 
    iobref=0x180a4e0, xdata=0x0) at md-cache.c:1360
#3  0x00007fd9a4e561e0 in ioc_frame_unwind (frame=0x7fd9a87b7184) at page.c:872
#4  0x00007fd9a4e563ad in ioc_frame_return (frame=0x7fd9a87b7184) at page.c:914
#5  0x00007fd9a4e54b87 in ioc_waitq_return (waitq=0x7fd998001590) at page.c:402
#6  0x00007fd9a4e550d3 in ioc_fault_cbk (frame=0x7fd9a85af82c, cookie=0x7fd9a87b72dc, this=0x1815230, op_ret=-1, op_errno=116, vector=0x186fac0, count=0, stbuf=0x186f968, iobref=0x180aba0, 
    xdata=0x0) at page.c:530
#7  0x00007fd9a5065317 in ra_frame_unwind (frame=0x7fd9a87b72dc) at page.c:441
#8  0x00007fd9a506543a in ra_frame_return (frame=0x7fd9a87b72dc) at page.c:476
#9  0x00007fd9a50643ee in ra_waitq_return (waitq=0x7fd998001400) at page.c:125

Observe that io-cache got an op_ret -1 but it unwinds with op_ret 0.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2013-01-29 14:01:49 EST
CHANGE: http://review.gluster.org/4204 (performance/io-cache: propagate errors while unwinding frame in                       read path.) merged in master by Anand Avati (avati@redhat.com)
Comment 2 Niels de Vos 2014-04-17 07:39:05 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.