Bug 858246 - CIM could not be set successfully after upgrading from 6.2 to 6.3
CIM could not be set successfully after upgrading from 6.2 to 6.3
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Mike Burns
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-18 08:23 EDT by Meng Liang
Modified: 2016-04-26 10:37 EDT (History)
13 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-8.el6
Doc Type: Bug Fix
Doc Text:
In certain Red Hat Enterprise Virtualization Hypervisor upgrade conditions, the CIM user is not created correctly, causing errors when CIM is enabled and a password is added. This fix adds validation to the set_password function to ensure that the user is setup and correctly configured prior to setting the password.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:39:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of error message (1.25 MB, image/jpeg)
2012-09-18 08:25 EDT, Meng Liang
no flags Details
screenshot of the empty page (1.68 MB, image/jpeg)
2012-09-18 08:26 EDT, Meng Liang
no flags Details

  None (edit)
Description Meng Liang 2012-09-18 08:23:30 EDT
Description of problem:
CIM could not be set successfully after upgrading from rhev-hypervisor6-6.2-20120605.0.el6_2 to  rhev-hypervisor6-6.3-20120913.0.el6_3 on RHEVM

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20120913.0.el6_3

How reproducible:
Always

Steps to Reproduce:
1. Install rhev-hypervisor6-6.2-20120605.0.el6_2
2. register rhevh to rhevm (ic157)
3. upgrade rhevh to rhev-hypervisor6-6.3-20120913.0.el6_3 via RHEVM
4. enable CIM and provide correct password.

Actual results:
Error message(see attached figure) shows press 'ok' to return to the configure page.
Enable CIM and enter password again, empty page shows(see attached figure)
The only way to go back to configure page is press F2 to command line and enter 'exit'
CIM still display as 'disable' after setting to 'enable'

Expected results:
CIM could be enable successfully without error message.

Additional info:
Comment 1 Meng Liang 2012-09-18 08:25:05 EDT
Created attachment 613993 [details]
screenshot of error message
Comment 2 Meng Liang 2012-09-18 08:26:21 EDT
Created attachment 613994 [details]
screenshot of the empty page
Comment 4 Mike Burns 2012-10-12 17:22:15 EDT
This works correctly with upgrade from media.  testing now with upgrade from rhevm.
Comment 5 Mike Burns 2012-10-12 18:00:43 EDT
Fails with upgrade from RHEV-M. 

The cim user does not exist.  I'm not sure if that is the root cause or not, but it certainly doesn't help.

Thoughts for fixing:

alter cim.py to:

check for the cim user
If it does not exist create it with a command like:

unmount_config /etc/shadow /etc/passwd
useradd -G sfcb -g cim -s /sbin/nologin cim
persist /etc/shadow /etc/password

then proceed with setting password, enabling the service, etc.
Comment 6 Mike Burns 2012-10-13 08:59:45 EDT
Upstream patch:

http://gerrit.ovirt.org/8524
Comment 7 Mike Burns 2012-10-15 18:54:11 EDT
Patch failed in dev testing, needs additional work
Comment 14 errata-xmlrpc 2013-02-28 11:39:05 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.