Bug 858251 - [RFE]: scl command should have bash completion. PATCH included.
[RFE]: scl command should have bash completion. PATCH included.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: scl-utils (Show other bugs)
6.3
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: Jan Zeleny
BaseOS QE - Apps
: FutureFeature, Patch
Depends On: 858248
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-18 08:40 EDT by Miroslav Hradílek
Modified: 2014-04-10 03:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 858248
Environment:
Last Closed: 2014-04-10 03:53:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Miroslav Hradílek 2012-09-18 08:40:38 EDT
+++ This bug was initially created as a clone of Bug #858248 +++

Description of problem:

Utility scl is called on a regular basis and it is annoying to write everything by hand every time.

Expected results:

Bash completion should complete available scriptlets and collections automatically.

--- Additional comment from mhradile@redhat.com on 2012-09-18 08:33:26 EDT ---

Created attachment 613999 [details]
Proposed patch

Also Patch added :)
Comment 2 Tom Lavigne 2012-09-18 11:51:12 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Since Red Hat is unable to address this request at this time, 
it has been proposed for the next release of Red Hat Enterprise 
Linux.
Comment 3 RHEL Product and Program Management 2013-10-14 00:46:56 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 Jan Zeleny 2014-04-10 03:53:14 EDT
The bash completion script is already available in Fedora and RHEL7. Considering the plan to minimize changes in RHEL6 to only those critical to our layered products, we don't plan to implement this in RHEL6.

Note You need to log in before you can comment on or make changes to this bug.