Bug 858256 - volume attach fails with iscsiadm --login timeout
volume attach fails with iscsiadm --login timeout
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openstack-cinder (Show other bugs)
18
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Pádraig Brady
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-18 09:11 EDT by Eoghan Glynn
Modified: 2012-12-20 10:07 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:07:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CPAN 79869 None None None 2012-09-26 19:00:20 EDT

  None (edit)
Description Eoghan Glynn 2012-09-18 09:11:55 EDT
Description of problem:

Attempt to attach a volume to a nova instance fails with the following error in the nova-compute log:

  'iscsiadm: Could not login to [iface: default, target: iqn.2010-10.org.openstack:volume-81d30c1d-a932-4e03-babe-c8584bcc45ed, portal: 192.168.0.6,3260].\niscsiadm: initiator reported error (8 - connection timed out)\niscsiadm: Could not log into all portals\n'


Version-Release number of selected component (if applicable):

openstack-nova-compute-2012.2-0.7.f3.fc18.noarch


How reproducible:

100%


Steps to Reproduce:
1. Create a volume
2. Attach the volume to an instance
3. Monitor the volume status through 'attaching' back to 'available'


Actual results:

The volume status fails to reach 'in-use'.


Expected results:

The volume status transitions to 'in-use'.
Comment 2 Mark McLoughlin 2012-09-20 06:08:09 EDT
The issue turns out to be that the iSCSI target was never actually getting created

We need tgtd to include volumes configurations from /var/lib/nova/volumes as described here:

  http://lists.fedoraproject.org/pipermail/cloud/2012-July/001593.html
Comment 3 Eoghan Glynn 2012-09-20 10:20:43 EDT
Small correction, it should include /var/lib/cinder/volumes in the tgtd.conf, i.e.:

  sudo sed -i '1iinclude /var/lib/cinder/volumes/*' /etc/tgt/targets.conf
Comment 4 Fedora Update System 2012-09-21 13:53:29 EDT
openstack-cinder-2012.2-0.5.rc1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/openstack-cinder-2012.2-0.5.rc1.fc18
Comment 5 Fedora Update System 2012-09-22 02:33:10 EDT
openstack-cinder-2012.2-0.5.rc1.fc18 has been pushed to the Fedora 18 testing repository.
Comment 6 Mark McLoughlin 2012-09-24 11:29:45 EDT
FYI - for this to work on F17, you need this scsi-target-utils update:

https://admin.fedoraproject.org/updates/FEDORA-2012-14471/scsi-target-utils-1.0.24-4.fc17
Comment 7 Eoghan Glynn 2012-09-25 10:06:47 EDT
Re-opening as the work-around:

  # 1. remove non-globbed conf fragments
  sudo rm /etc/tgt/conf.d/{nova,cinder}.conf
  # 2. ensure that target config in /etc/cinder/volume picked up
  # after tgtd restart
  sudo sed -i '1iinclude /etc/cinder/volumes/*' /etc/tgt/targets.conf

is still required.

#2 in particular required to ensure that a volume created before a tgtd restart is still usable afterwards.
Comment 8 Pádraig Brady 2012-09-25 10:11:49 EDT
It seems nested includes as discussed in bug #643302 is supported,
but nested globbing is not. Investigating.
Comment 9 Mark McLoughlin 2012-09-25 10:30:14 EDT
This recent patch - https://review.openstack.org/12542 - is actually a part of the confusion here

We didn't have this patch during the first test day and volume attach was failing

However, in the second test day, this patch was in and attach works fine without any inclusion targets.conf

The problem is that if you restart tgtd without the targets.conf inclusion, the targets disappear - this is the issue that the persistent targets work in Folsom was intended to fix
Comment 10 Pádraig Brady 2012-09-26 19:28:55 EDT
Possible solution detailed at bug 643302#c14
Comment 11 Fedora Update System 2012-09-27 13:37:53 EDT
openstack-nova-2012.2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/openstack-nova-2012.2-1.fc18
Comment 12 Fedora Update System 2012-09-27 13:40:44 EDT
openstack-nova-2012.2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/openstack-nova-2012.2-1.fc18
Comment 13 Fedora Update System 2012-09-27 13:42:59 EDT
openstack-cinder-2012.2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/openstack-cinder-2012.2-1.fc18
Comment 14 Fedora Update System 2012-09-28 13:21:34 EDT
openstack-cinder-2012.2-1.fc18 has been pushed to the Fedora 18 testing repository.
Comment 15 Fedora Update System 2012-12-20 10:07:49 EST
openstack-cinder-2012.2-0.5.rc1.fc18 has been pushed to the Fedora 18 obsolete repository.

Note You need to log in before you can comment on or make changes to this bug.