Bug 858296 - Disk encryption failed during install
Disk encryption failed during install
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-18 11:30 EDT by Florian "der-flo" Lehner
Modified: 2012-11-22 21:17 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-22 21:17:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian "der-flo" Lehner 2012-09-18 11:30:32 EDT
Description of problem:
In custom partition setup screen you are not asked for an encryption passphrase.

Version-Release number of selected component (if applicable):
$ sha256sum Fedora-18-Alpha-x86_64-Live-XFCE.iso 
03d164ab34e372b7f754996da864bd1c4d4115ea4ea446274cee90ef1a1a1a42  Fedora-18-Alpha-x86_64-Live-XFCE.iso

How reproducible:
Always

Steps to Reproduce:
1. Boot, launch Anaconda from Desktop, select language and accept fate
2. Start custom partitioning
3. check the "encryption"-option next to a partition
  
Actual results:
partition is not encrypted

Expected results:
ask for passphrase and encrypt the partition

Additional info:
Comment 1 Adam Williamson 2012-11-22 21:17:59 EST
This bug looks to have been fixed for many anaconda builds now but missed being closed. If you find you are still experiencing it with Fedora 18 Beta (RC1) or later, please re-open the bug.

(I've tested this in Beta TCs in the course of testing other stuff, it worked fine.)

Note You need to log in before you can comment on or make changes to this bug.