Bug 858321 - Permissions on rdma devices changed after updating from RHEL 6.2 to RHEL 6.3
Permissions on rdma devices changed after updating from RHEL 6.2 to RHEL 6.3
Status: CLOSED DUPLICATE of bug 834428
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rdma (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Doug Ledford
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-18 12:04 EDT by Elvir Kuric
Modified: 2012-09-19 18:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-19 18:22:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elvir Kuric 2012-09-18 12:04:26 EDT
Description of problem:

In RHEL 6.2 the permission for the Infiniband devices where as follows:

crw-rw----  1 root root 231,  64 Jul 21 21:05 issm0
crw-rw----  1 root root 231,  65 Jul 21 21:05 issm1
crw-rw-rw-  1 root root  10,  58 Jul 21 21:05 rdma_cm
crw-rw-rw-  1 root root 231, 224 Jul 21 21:05 ucm0
crw-rw----  1 root root 231,   0 Jul 21 21:05 umad0
crw-rw----  1 root root 231,   1 Jul 21 21:05 umad1
crw-rw-rw-  1 root root 231, 192 Jul 21 21:05 uverbs0

With RHEL 6.3 it changed to:

crw-rw----  1 root root 231,  64 Aug  2 22:33 issm0
crw-rw----  1 root root 231,  65 Aug  2 22:33 issm1
crw-rw----  1 root root  10,  58 Aug  2 22:33 rdma_cm
crw-rw----  1 root root 231, 224 Aug  2 22:33 ucm0
crw-rw----  1 root root 231,   0 Aug  2 22:33 umad0
crw-rw----  1 root root 231,   1 Aug  2 22:33 umad1
crw-rw----  1 root root 231, 192 Aug  2 22:33 uverbs0



Version-Release number of selected component (if applicable):

rdma-3.3-3.el6 

How reproducible:

Upgrade from RHEL 6.2 ( and rdma-1.0.14 ) to RHEL 6.3 ( and rdma-3.3-3.el6  ) 

  
Actual results:

permissions on rdma devices changed in RHEL 6.3 

Expected results:

to preserve permissions as it was case in RHEL 6.3 

Additional info:

The file /etc/udev/rules.d/90-rdma.rules was removed from rdma with version rdma-3.3-3.el6,but it should be replaced with below  udev rules - to maintain the correct file permissions:

KERNEL=="ucm*", MODE="0666"
KERNEL=="uverbs*",MODE="0666"
KERNEL=="uat", MODE="0666"
KERNEL=="ucma", MODE="0666"
KERNEL=="rdma_cm", MODE="0666"
Comment 2 Doug Ledford 2012-09-19 18:22:18 EDT

*** This bug has been marked as a duplicate of bug 834428 ***

Note You need to log in before you can comment on or make changes to this bug.