This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 858378 - NFS volume not mounted on boot
NFS volume not mounted on boot
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-18 15:49 EDT by Pete Zaitcev
Modified: 2012-10-13 10:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-13 10:02:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pete Zaitcev 2012-09-18 15:49:23 EDT
Description of problem:

After a boot, volume not mounted.

Version-Release number of selected component (if applicable):

kernel-3.6.0-0.rc2.git2.1.fc18.x86_64
nfs-utils-1.2.6-11.fc18.x86_64
systemd-188-3.fc18.x86_64

How reproducible:

100%

Steps to Reproduce:
1. Add an NFS share in /etc/fstab (make sure it's not "noauto")
2. reboot
  
Actual results:

Filesystem is not mounted.

Expected results:

Filesystem is mounted.

Additional info:

#
# /etc/fstab
# Created by anaconda on Wed Jun 13 20:14:17 2012
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
/dev/mapper/vg_kvm--ichi-lv00 /                 ext4    defaults        1 1
UUID=65e38f15-bfb8-4eac-8f3e-bd4bf732c388 /boot ext2    defaults        1 2
/dev/mapper/vg_kvm--ichi-lvswap swap            swap    defaults        0 0
/dev/vdb		/mnt/vdb		xfs	defaults	1 2
/dev/vdc		/mnt/vdc		xfs	defaults	1 2
simbelmyne:/q/zaitcev   /q/zaitcev              nfs     noatime,nolock,defaults 1 2
simbelmyne.zaitcev.lan:/g	/mnt/g    glusterfs	defaults,_netdev,noauto 0 0

This actually started after a "yum update" in F17 before the system
was upgraded to F18 Alpha 3. There's also another box with the same
problem that has Rawhide. Probably very similar packages all across
the current F17, F18, and Rawhide.

This used to work, fstab not changed.

Running "mount /q/zaitcev" after boot succeeds.

Component may be not nfs-utils. No clue what the problem is really.
Comment 1 Steve Dickson 2012-10-13 10:02:32 EDT
I added a NFS mount entry to /etc/fstab on both a updated f17 VM and a f18 VM. The file system got mount on a reboot on both VMs... So whatever was broken has not heeled... The next time this happen, as root, type "mount -a" to see the error message.

Note You need to log in before you can comment on or make changes to this bug.