This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 858390 - local yum repository sees all custom rpm's except one rpm
local yum repository sees all custom rpm's except one rpm
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum (Show other bugs)
5.6
x86_64 Linux
unspecified Severity low
: rc
: ---
Assigned To: packaging-team-maint
BaseOS QE Security Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-18 16:45 EDT by matthew
Modified: 2014-01-21 01:25 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-22 11:30:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
offending rpm (41.46 MB, application/octet-stream)
2012-09-18 16:45 EDT, matthew
no flags Details

  None (edit)
Description matthew 2012-09-18 16:45:53 EDT
Created attachment 614115 [details]
offending rpm

Description of problem:

I am unable to install a custom rpm from my local repository.
All custom rpms in this repository show from other server trying to install it via yum install, except for this one.

I cannot imagine why this would happen for only one rpm, unless there is something wrong with the rpm. 

Doesn't yum just look at an rpm file and install it?

I cannot install this crucial rpm as a result via yum. 
I verified it is in the repository (createrepo -v --update .) and I checked the repository metadata (zcat x86_64/repodata/*.gz | grep mycustomrpm) and it shows up.

I did notice that running a rpm -ivvh showed some information that it's built for i386 it seems, so I added it to my i386 repository but I imagine yum see's it's an x86_64 system and then doesn't utilize this repository. I can't imagine this is the issue though because I've install i386 packages on x86 system before.

I also tried yum install custompackage.i386 to specify i386 repo but it still doesn't see it.

Version-Release number of selected component (if applicable):

Red Hat Enterprise Linux Server release 5.6 (Tikanga)

Linux ip-10-24-14-20 2.6.18-238.9.1.el5xen #1 SMP Fri Mar 18 12:53:42 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux




createrepo-0.4.11-3.el5
[root@ ~]# rpm -qa | grep yum       
yum-metadata-parser-1.1.2-3.el5.centos
yum-fastestmirror-1.1.16-14.el5.centos.1
yum-updatesd-0.9-2.el5
yum-utils-1.1.16-14.el5.centos.1
yum-3.2.22-33.el5.centos



How reproducible:
Ever time.

Steps to Reproduce:
1 I added a custom rpm to my local yum repository.
2 I ran createrepo --update . 
3 I try to run yum install customrpm, and it doesn't see it.
  
Actual results:

Loaded plugins: amazon-id, fastestmirror, priorities, security
Loading mirror speeds from cached hostfile
 * base: mirror.symnds.com
 * extras: mirror.symnds.com
 * update: mirror.ash.fastserv.com
44 packages excluded due to repository priority protections
Setting up Install Process
No package SumoLogic available.
Nothing to do

Expected results:

It installs the RPM via yum

Additonal Info:
Comment 1 Zdeněk Pavlas 2013-03-22 11:30:06 EDT
> SumoCollector_linux_64_19_9-2.rpm

I've downloaded the RPM, and queried it.  The package name is SumoCollector-19.9-2-1.i386

> I try to run yum install customrpm, and it doesn't see it.
> ..
> No package SumoLogic available.

Seems you have tried to install "SumoLogic".  Try installing "SumoCollector" instead.

Note You need to log in before you can comment on or make changes to this bug.