Bug 858417 - X-Account-Container-Count and X-Container-Count numbers are not reflecting accurate count
X-Account-Container-Count and X-Container-Count numbers are not reflecting ac...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gluster-swift (Show other bugs)
2.0
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: Luis Pabón
pushpesh sharma
:
Depends On: 833179
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-18 18:19 EDT by Scott Haines
Modified: 2016-11-08 17:24 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 833179
Environment:
Last Closed: 2013-09-23 18:32:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Junaid 2013-04-03 01:18:32 EDT
Fixed upstream.
Comment 3 pushpesh sharma 2013-07-16 07:36:44 EDT
 Verified original Bug :- https://bugzilla.redhat.com/show_bug.cgi?id=833179

Issue no longer seen in RHS2.1.

Verified with object_only=yes/no,as follows :- 

[psharma@dhcp193-66 dummy_files]$ curl -X PUT -H 'X-Auth-Token: AUTH_tk333998bd65df4c9aade2da934af97268' http://10.65.207.210:8080/v1/AUTH_test2/dir1
[psharma@dhcp193-66 dummy_files]$ curl -X PUT -H 'X-Auth-Token: AUTH_tk333998bd65df4c9aade2da934af97268' http://10.65.207.210:8080/v1/AUTH_test2/dir2
[psharma@dhcp193-66 dummy_files]$ curl -X PUT -H 'X-Auth-Token: AUTH_tk333998bd65df4c9aade2da934af97268' http://10.65.207.210:8080/v1/AUTH_test2/dir3
[psharma@dhcp193-66 dummy_files]$ curl -X PUT -H 'X-Auth-Token: AUTH_tk333998bd65df4c9aade2da934af97268' http://10.65.207.210:8080/v1/AUTH_test2/dir4
[psharma@dhcp193-66 dummy_files]$ curl -X PUT -H 'X-Auth-Token: AUTH_tk333998bd65df4c9aade2da934af97268' http://10.65.207.210:8080/v1/AUTH_test2/dir5
[psharma@dhcp193-66 dummy_files]$ curl -X PUT -H 'X-Auth-Token: AUTH_tk333998bd65df4c9aade2da934af97268' http://10.65.207.210:8080/v1/AUTH_test2/dir6
[psharma@dhcp193-66 dummy_files]$ curl -X PUT -H 'X-Auth-Token: AUTH_tk333998bd65df4c9aade2da934af97268' http://10.65.207.210:8080/v1/AUTH_test2/dir7
[psharma@dhcp193-66 dummy_files]$ curl -X PUT -H 'X-Auth-Token: AUTH_tk333998bd65df4c9aade2da934af97268' http://10.65.207.210:8080/v1/AUTH_test2/dir8
[psharma@dhcp193-66 dummy_files]$ curl -X PUT -H 'X-Auth-Token: AUTH_tk333998bd65df4c9aade2da934af97268' http://10.65.207.210:8080/v1/AUTH_test2/dir9
[psharma@dhcp193-66 dummy_files]$ curl -X PUT -H 'X-Auth-Token: AUTH_tk333998bd65df4c9aade2da934af97268' http://10.65.207.210:8080/v1/AUTH_test2/dir10
[psharma@dhcp193-66 dummy_files]$ curl -v -X HEAD -H 'X-Auth-Token: AUTH_tk333998bd65df4c9aade2da934af97268' http://10.65.207.210:8080/v1/AUTH_test2
* About to connect() to 10.65.207.210 port 8080 (#0)
*   Trying 10.65.207.210... connected
* Connected to 10.65.207.210 (10.65.207.210) port 8080 (#0)
> HEAD /v1/AUTH_test2 HTTP/1.1
> User-Agent: curl/7.21.7 (x86_64-redhat-linux-gnu) libcurl/7.21.7 NSS/3.13.5.0 zlib/1.2.5 libidn/1.22 libssh2/1.2.7
> Host: 10.65.207.210:8080
> Accept: */*
> X-Auth-Token: AUTH_tk333998bd65df4c9aade2da934af97268
> 
< HTTP/1.1 204 No Content
< Content-Length: 0
< X-Account-Container-Count: 10
< Accept-Ranges: bytes
< X-Account-Object-Count: 0
< X-Bytes-Used: 0
< X-Timestamp: 1373872319.01700
< X-Object-Count: 0
< X-Account-Bytes-Used: 0
< X-Type: Account
< Content-Type: text/plain; charset=utf-8
< X-Container-Count: 10
< Date: Tue, 16 Jul 2013 09:51:35 GMT
< 
* Connection #0 to host 10.65.207.210 left intact
* Closing connection #0
[psharma@dhcp193-66 dummy_files]$ curl -X DELETE -H 'X-Auth-Token: AUTH_tk333998bd65df4c9aade2da934af97268' http://10.65.207.210:8080/v1/AUTH_test2/dir6
[psharma@dhcp193-66 dummy_files]$ curl -v -X HEAD -H 'X-Auth-Token: AUTH_tk333998bd65df4c9aade2da934af97268' http://10.65.207.210:8080/v1/AUTH_test2
* About to connect() to 10.65.207.210 port 8080 (#0)
*   Trying 10.65.207.210... connected
* Connected to 10.65.207.210 (10.65.207.210) port 8080 (#0)
> HEAD /v1/AUTH_test2 HTTP/1.1
> User-Agent: curl/7.21.7 (x86_64-redhat-linux-gnu) libcurl/7.21.7 NSS/3.13.5.0 zlib/1.2.5 libidn/1.22 libssh2/1.2.7
> Host: 10.65.207.210:8080
> Accept: */*
> X-Auth-Token: AUTH_tk333998bd65df4c9aade2da934af97268
> 
< HTTP/1.1 204 No Content
< Content-Length: 0
< X-Account-Container-Count: 9
< Accept-Ranges: bytes
< X-Account-Object-Count: 0
< X-Bytes-Used: 0
< X-Timestamp: 1373872319.01700
< X-Object-Count: 0
< X-Account-Bytes-Used: 0
< X-Type: Account
< Content-Type: text/plain; charset=utf-8
< X-Container-Count: 9
< Date: Tue, 16 Jul 2013 09:51:49 GMT
< 
* Connection #0 to host 10.65.207.210 left intact
* Closing connection #0
[psharma@dhcp193-66 dummy_files]$


[root@dhcp207-210 ~]# rpm -qa|grep gluster
gluster-swift-object-1.8.0-6.3.el6rhs.noarch
vdsm-gluster-4.10.2-22.7.el6rhs.noarch
gluster-swift-plugin-1.8.0-2.el6rhs.noarch
glusterfs-geo-replication-3.4.0.12rhs.beta3-1.el6rhs.x86_64
glusterfs-3.4.0.12rhs.beta3-1.el6rhs.x86_64
gluster-swift-1.8.0-6.3.el6rhs.noarch
glusterfs-server-3.4.0.12rhs.beta3-1.el6rhs.x86_64
gluster-swift-proxy-1.8.0-6.3.el6rhs.noarch
gluster-swift-account-1.8.0-6.3.el6rhs.noarch
glusterfs-rdma-3.4.0.12rhs.beta3-1.el6rhs.x86_64
glusterfs-fuse-3.4.0.12rhs.beta3-1.el6rhs.x86_64
gluster-swift-container-1.8.0-6.3.el6rhs.noarch
Comment 4 Scott Haines 2013-09-23 18:32:24 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.